0

I'm somewhat of a beginner when it comes to Ubuntu and certainly inexperienced in networking, and after hours of searching the internet for solutions, I can't find how to fix my problem. I'm hoping someone can help me because this is urgent and frustrating XD

As the title states, under the Network Manager taskbar icon, the option to 'Enable Wifi' has completely disappeared. The 'Enable Networking' option is there, but even though a popup will say I'm 'Connected to Wired Connection 1', I won't get any internet access. The machine is dual boot with Windows 10, and that connects to Wifi automatically and can establish a wired connection with internet. This leads me to believe there is a driver issue, but I don't know. I was not the one to install Ubuntu 14.04 on here, so I don't know if third-party drivers were installed, etc.

Here are some outputs to commands and contents of files that I've seen are commonly asked for, let me know if I've missed anything else:

System Information, because AskUbuntu won't let me embed an image yet

$ ifconfig

eth0      Link encap:Ethernet  HWaddr 30:9c:23:25:cb:11  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:16 Memory:df200000-df220000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:143 errors:0 dropped:0 overruns:0 frame:0
          TX packets:143 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:10085 (10.0 KB)  TX bytes:10085 (10.0 KB)

$ route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface

The output to route -n is otherwise empty, so there's obviously something wrong there.

Contents of /etc/resolve/conf and /etc/resolvconf/resolv.conf.d/head:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN

Again, it's otherwise empty, so there's something wrong there too.

$ ping -c4 localhost
PING localhost (127.0.0.1) 56(84) bytes of data.
64 bytes from localhost (127.0.0.1): icmp_seq=1 ttl=64 time=0.047 ms
64 bytes from localhost (127.0.0.1): icmp_seq=2 ttl=64 time=0.033 ms
64 bytes from localhost (127.0.0.1): icmp_seq=3 ttl=64 time=0.037 ms
64 bytes from localhost (127.0.0.1): icmp_seq=4 ttl=64 time=0.031 ms

--- localhost ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 2999ms
rtt min/avg/max/mdev = 0.031/0.037/0.047/0.006 ms

$ ping 8.8.8.8
connect: Network is unreachable

$ ping google.com
ping: unknown host google.com

$ sudo lshw -C network
  *-network               
       description: Ethernet interface
       product: Ethernet Connection (2) I219-V
       vendor: Intel Corporation
       physical id: 1f.6
       bus info: pci@0000:00:1f.6
       logical name: eth0
       version: 00
       serial: 30:9c:23:25:cb:11
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=0.8-4 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:131 memory:df200000-df21ffff

Contents of /var/lib/NetworkManager/NetworkManager.state

[main]
NetworkingEnabled=true
WirelessEnabled=true
WWANEnabled=true
WimaxEnabled=true

I've tried the following:

  1. sudo service network-manager stop/start/restart
  2. killall unity-panel-service
  3. /usr/lib/unity/unity-panel-service
  4. sudo rfkill unblock all
  5. sudo dpkg-reconfigure resolvconf

And I've probably tried a lot more than that.

If anyone has any suggestions, I'd greatly appreciate them. Thank you!

-Nick

UPDATE 1

After setting a static IP:

$ ifconfig
eth0      Link encap:Ethernet  HWaddr 30:9c:23:25:cb:11  
          inet addr:192.168.86.181  Bcast:192.168.86.255  Mask:255.255.255.0
          inet6 addr: fe80::329c:23ff:fe25:cb11/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6820 errors:0 dropped:2 overruns:0 frame:0
          TX packets:363 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:670993 (670.9 KB)  TX bytes:55189 (55.1 KB)
          Interrupt:16 Memory:df200000-df220000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2442 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2442 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:282394 (282.3 KB)  TX bytes:282394 (282.3 KB)

And the info returned from lsmod:

$ lsmod
Module                  Size  Used by
uas                    24576  0 
usb_storage            69632  1 uas
bnep                   20480  2 
rfcomm                 69632  0 
nvidia_uvm            647168  0 
nvidia_drm             45056  1 
nvidia_modeset        860160  4 nvidia_drm
binfmt_misc            20480  1 
nvidia              13144064  189 nvidia_modeset,nvidia_uvm
joydev                 20480  0 
input_leds             16384  0 
snd_hda_codec_realtek    90112  1 
snd_hda_codec_generic    73728  1 snd_hda_codec_realtek
i915_bpo             1306624  0 
snd_hda_codec_hdmi     53248  1 
intel_ips              20480  1 i915_bpo
i2c_algo_bit           16384  1 i915_bpo
snd_hda_intel          40960  5 
snd_hda_codec         135168  4     snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel
snd_hda_core           73728  5     snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               106496  4
snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
hci_uart               77824  0 
intel_rapl             20480  0 
x86_pkg_temp_thermal    16384  0 
intel_powerclamp       16384  0 
coretemp               16384  0 
kvm_intel             167936  0 
btbcm                  16384  1 hci_uart
btqca                  16384  1 hci_uart
btintel                16384  1 hci_uart
bluetooth             516096  14 bnep,btbcm,btqca,hci_uart,rfcomm,btintel
kvm                   536576  1 kvm_intel
snd_seq_midi           16384  0 
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            32768  1 snd_seq_midi
snd_seq                69632  2 snd_seq_midi_event,snd_seq_midi
drm_kms_helper        151552  2 i915_bpo,nvidia_drm
snd_seq_device         16384  3 snd_seq,snd_rawmidi,snd_seq_midi
snd_timer              32768  2 snd_pcm,snd_seq
snd                    81920  21     snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel,snd_seq_device
drm                   360448  5 i915_bpo,drm_kms_helper,nvidia_drm
fb_sys_fops            16384  1 drm_kms_helper
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
mxm_wmi                16384  0 
soundcore              16384  1 snd
serio_raw              16384  0 
shpchp                 36864  0 
irqbypass              16384  1 kvm
crct10dif_pclmul       16384  0 
crc32_pclmul           16384  0 
ghash_clmulni_intel    16384  0 
aesni_intel           167936  0 
mei_me                 36864  0 
mei                    98304  1 mei_me
aes_x86_64             20480  1 aesni_intel
lrw                    16384  1 aesni_intel
gf128mul               16384  1 lrw
glue_helper            16384  1 aesni_intel
ablk_helper            16384  1 aesni_intel
cryptd                 20480  3
ghash_clmulni_intel,aesni_intel,ablk_helper
i2c_hid                20480  0 
8250_fintek            16384  0 
video                  40960  1 i915_bpo
intel_lpss_acpi        16384  0 
intel_lpss             16384  1 intel_lpss_acpi
mac_hid                16384  0 
acpi_als               16384  0 
kfifo_buf              16384  1 acpi_als
industrialio           57344  2 acpi_als,kfifo_buf
acpi_pad               24576  0 
wmi                    20480  1 mxm_wmi
parport_pc             36864  1 
ppdev                  20480  0 
lp                     20480  0 
parport                49152  3 lp,ppdev,parport_pc
hid_generic            16384  0 
usbhid                 49152  0 
hid                   118784  3 i2c_hid,hid_generic,usbhid
e1000e                233472  0 
psmouse               131072  0 
ptp                    20480  1 e1000e
pps_core               20480  1 ptp
ahci                   36864  3 
libahci                32768  1 ahci
fjes                   28672  0 
0

As far as I can see, your network is up (ifconfig eth0) but it has no IP address. So either supply a static ip address to the link or get one through dhcp.

  • For the wireless issue, can you verify if the network driver module is loaded ? (lsmod) – Bart J. Feb 9 '18 at 16:26
  • I've updated the original post. Thank you for the help! – Nick Vandemark Feb 9 '18 at 17:39
  • You also need to set a gateway to get internet connection. $sudo route add default gw <IPADDRESS OF THE GATEWAY> . Then ping the gateway IP address and see if that works ... route -n should now show your gateway. – Bart J. Feb 9 '18 at 18:13
  • Also, seeing that lshw -C network doesn't show anything about a wireless card ... I don't think the driver/module is loaded ... – Bart J. Feb 9 '18 at 18:20
  • How do I know what gateway I should use? Again, I'm very novice when it comes to networking. And about the wireless card - I should have mentioned that it was working at one point when I had a wireless usb adapter, but then that broke. I could get wifi without it, but then shortly after it disconnected and the option never came back. So I'm not sure what that means if it was working at one point but not anymore. – Nick Vandemark Feb 9 '18 at 18:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.