1

I have a problem that I'm trying to solve for a long time. I'm using Ubuntu 16.04 dual boot with Windows 10:

When I'm using several tabs in Firefox or Chromium, I see significant memory usage. One tab takes up to 500MB of RAM and when it gets to 3,7GB Ram usage my pc freeze and only what I can do is hard-reset my pc.

I've tried several things to solve this problem:

  • Disabled all add-ons in Firefox (Firefox version is 58)
  • Update kernel to 4.13
  • Disabled "Use hardware acceleration when available" and made more thing to optimize Firefox performance
  • Tried to use Firefox in safe mode
  • Increased swapping vm.swappiness=10 and swap to 8gb

I have a total 4GB of RAM. I never had that problem using Windows before only this happens on Ubuntu.

free --human output:

              total        used        free      shared  buff/cache   available
Mem:           3,7G        1,2G        1,2G         50M        1,3G        2,2G
Swap:          8,1G          0B        8,1G

swapon output

Filename            Type        Size     Used   Priority
/swapfile           file        8388604     0         -1
/dev/sda5           partition   102396      0         -2

uname -r output

4.13.0-32-generic

What else can I try to solve the problem?

  • Add swap space. Read man mkswap;man swapon. – waltinator Feb 9 '18 at 16:19
  • 1
    that's not a solution for me, 4 tabs opened is not a lot + IDE is opened and nothing more – Viktor Feb 9 '18 at 16:20
  • "I see significant memory usage" is kind of vague, can you post any evidence. Also, which precesses use RAM the most? – mikewhatever Feb 9 '18 at 16:27
  • @mikewhatever Firefox tabs using the most memory it showing that one tab taking up to 400MB – Viktor Feb 9 '18 at 16:29
  • 1
    i edited the question with the output of free-h and swapon -s – Viktor Feb 11 '18 at 17:34
-1

What you're running into is called swapping: You're out of RAM and the kernel swaps unused programs to disk. Setting swappiness to 10 just means the kernel is swapping later rather than earlier (as the default is 60).

As swapping to disk is 1000 times slower than using RAM it just looks like your PC is freezing, but it's not.

You have a few options:

  • Don't use Chromium: that's a real memory hog; stick to Firefox only!
  • Use AdBlock+ (advertisements eat memory too)
  • Use NoScript (only allow the scripts you need on the pages you need)
  • Use fewer tabs
  • set swappiness back to 60 and be patient when swapping

and the easiest solution of all:

  • Buy more RAM

(also the most expensive)

  • The free is after boot, not when the problem is happening as by then hard reset is done. Let's see what reaction your comment gets. – Fabby Feb 19 '18 at 0:03
  • 1
    @userunknown ¯\_(ツ)_/¯ – Fabby Feb 19 '18 at 18:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.