1

I tried adding my Canon printer via wireless connenction to my laptop. I used this driver provided by canon: https://www.canon-europe.com/support/consumer_products/products/printers/laser/i-sensys_lbp6230dw.aspx?type=drivers&language=EN&os=Linux%20(64-bit) If I install any newer version (I found v 3.40 instead of 1.40) it won't even recognize the printer, stating it's generic tex-only printer, and even worse, in this case the printing job immediately gets cancelled in the minute I press the print button.

Using the 1.40 driver, the printer has been added, and even softwares (LibreOffice, even emulated MS Office) see the the printer, but it's stuck at "processing" for some reason I don't quite understand. If I have look at the error message it shows: " - src = bidiCommon.c, line = 349, err = 0¥nDEBUG2: prtMarkerSuppliesLevel.1.1 = 100" More to that, I know that the ink level is not full (if the value indicates that), because it can't even print the user data page properly.

The system sees the printer, when I run lpinfo -v, I get these results:

  • file cups-brf:/
  • network lpd
  • network http
  • network beh
  • network socket
  • network ipps
  • network ipp
  • direct hp
  • network https
  • direct hpfax
  • network bjnp
  • List item

network dnssd://Canon%20LBP6230dw._pdl-datastream._tcp.local/

  • network socket://192.168.0.94

I suspected something must be with the wireless connection, so I pinged the IP adress, the result I think shows, that something else is the problem, the result:

  • PING 192.168.0.94 (192.168.0.94) 56(84) bytes of data.
  • 7 packets transmitted, 7 received, 0% packet loss, time 6006ms rtt min/avg/max/mdev = 11.032/38.847/74.303/25.210 ms

In theory the port are open, because nmap gets this result:

Starting Nmap 7.60 ( https://nmap.org ) at 2018-02-09 11:42 CET Nmap scan report for 192.168.0.94 Host is up (0.041s latency). Not shown: 997 closed ports PORT STATE SERVICE 80/tcp open http 515/tcp open printer 9100/tcp open jetdirect Nmap done: 1 IP address (1 host up) scanned in 17.60 seconds

I'm sorry for the formatting,it's my first post here, so I didn't quite figure out when causes Enter a new paragraph. I highlighted wit bold font the text, which I think might be the most relevant.

I appreciate any help coming. Thank you in advance: David

  • 3
    Possible duplicate of Installing Canon LBP6000 in Ubuntu 12.04 – TimSparrow Feb 9 '18 at 11:17
  • Thanks for your suggestions. I tried following the steps in the instructions, but I don't have the CAPT drivers for my printer, only UFRII LT drivers according to the Canon site. The script didn't work as it's not one among the listed models, unfortunately. – KucsebarDavid Feb 9 '18 at 11:49
  • I had similar problems with Xerox 3030 Phaser laser printer. The problem was solved by replacing part of the printing libraries with their i386 counterparts, as x64 drivers had some incompatibilities. – TimSparrow Feb 9 '18 at 12:11
  • so Canon recommend the UFRII driver; support-asia.canon-asia.com/contents/ASIA/EN/0100595001.html at version 1.4 as you say; it was released 14th Nov 2017. There seem to be issues with 17.10 and the Canon UFR (version 3.4) and UFRII drivers; Canon updated them both Nov 2017; (presumably for 17.04) and I understood they were working on new drivers; one can only hope that 18.04; the LTS version will settle better; 17.10 has also had scanner issues; sadly it is the innovators who move ahead to new releases who discover these issues; – pdc Feb 10 '18 at 6:46
1

It is suggested that one edit the ppd file; /etc/cups/ppd/[yourprinter].ppd

and add the line

*CN_PDL_ConvertUserPaper: "dummy"


where it says [yourprinter]

this means find the ppd file relevant to your printer; in the folder ppd that is inside /etc/cups/


so if one uses the text editor gedit, the command would be

gksudo gedit /etc/cups/ppd/[yourprinter].ppd

.... but please do insert the correct name for your ppd file

I understand canon are working on a revision of the driver; note this is the 1.4 driver from here http://support-asia.canon-asia.com/contents/ASIA/EN/0100595001.html that comes down as linux-UFRIILT-drv-v140_uken.tar.gz so it is UFRIILT-drv-v140

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.