Sorry as im sure this comes up like a broken record but im really tired of having to do re install's of Lubuntu..

Im wanting to set it up as a LAMP with this link


All goes fine other then it only gives me PHP v 7.1 and i need to have 5.4 and 5.6 for my stuff to work..

I have tried many searches the last one being


and it just gave errors. Any advice on what i need to be doing?

Thanks In Advance

  • would give the error that it could not restart apache2... So I did a wipe and re install of Lubuntu so it's a fresh machine to work with – Shawn Kirk Feb 9 '18 at 1:14
  • Later Ubuntu's come with later versions of software; it's what users want, let alone later versions having security-fixes to known issues with older versions. I'd suggest updating your "stuff"; or using an older version of Ubuntu (ie. Ubuntu 16.04 LTS as your tutorial link expects) unless you want to upgrade your skills to deal to deal with varying levels of packages (and its consequences as it gets no/less testing)... – guiverc Feb 9 '18 at 1:21
  • There is no EASY solution for you: Ubuntu ships with pre-defined software versions (that support limitation is one reason it can be free), and neither 5.4 nor 5.6 are supported anymore. Someone with solid intermediate skills will know where to get those packages from and how to fix the inevitable problems. – user535733 Feb 9 '18 at 1:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.