2

So, I've switched to Ubuntu this week, it's all fine and good except for Chromecasting.

I installed Chrome but when I try to cast it says "No cast destinations found" even though it works from my phone.

I've tried Chromium and it does the same, I've also tried to install "Mkchromecast" after reading that that might help but "apt-get install mkchromecast" doesn't work and after downloading the .deb file, that won't install either.

Looking on Google there's not much to say this is happening for everyone, all I see are articles saying how much fun everyone's having Chromecasting.

Does anyone have any ideas how I can get this working? Or is it common knowledge that the Cast option in Chrome on Ubuntu is just there for decoration?

edit: see below comment about why this isn't a duplicate of the suggested question

edit: the ubuntu computer is connecting the same way as my phone, via wifi to the same router as the chromecast is on. I would have tried resetting the chromecast's connection from my computer following the steps on: https://support.google.com/chromecast/answer/2998456?co=GENIE.Platform%3DDesktop&hl=en but the "Set up your Chromecast using this computer" link doesn't show up and it seems you can only set up from a phone or tablet now.

edit: No VPN, firewall, or a proxy, unless something like that is used by default in Ubuntu somewhere but I doubt it is.

  • 2
    Can you give a very brief description of your network? Is this computer hooked up via WiFi or ethernet, and is it going into the same router as when you successfully cast from your phone? – thomasrutter Feb 9 '18 at 11:51
  • Are you using a VPN, firewall, or a proxy on your computer? – user68186 Feb 9 '18 at 15:04
  • any other suggestions folks? – captain_stupid Feb 10 '18 at 17:29
  • Try running avahi-browse -l --all That should show you your Chromecast. Also running arp -a should show your Chromecast. If those do not work then the issue is with your network. – Metta Crawler Feb 12 '18 at 1:00
  • Thanks for giving me something else to try. arp -a did show me the ip address of the chromecast. – captain_stupid Feb 12 '18 at 21:13
0

once my chromecast ultra was successfully set up with WIN7 it could no longer be seen in SETUP in WIN7, not even if you are connected to the casting network (and it successfully casts on that connection). Setup won't find it. In a WIKI I saw one is supposed to be able to reach the Ultra settings in Windows via the "Cast tab", but in Win 7 that doesnt work, likely the same issue in Linux/Ubuntu. Try factory hardware reset of your ULTRA, a small button depress 25 sec, next to the micro USB.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.