1

I want to install playonlinux on Ubuntu 17.10, I saw this question and its answer, But after sudo apt-get install playonlinux I am getting the following error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 playonlinux : Depends: curl
E: Unable to correct problems, you have held broken package

What can I do to fix this and get playonlinux installed?

sudo apt-get update :

arya@arya:~$ sudo apt-get update
Get:1 http://ppa.launchpad.net/noobslab/apps/ubuntu artful InRelease [15.4 kB] 
Ign:2 http://dl.google.com/linux/chrome/deb stable InRelease                   
Hit:3 http://archive.ubuntu.com/ubuntu artful InRelease                      
Hit:4 http://dl.google.com/linux/chrome/deb stable Release                     
Get:6 http://ppa.launchpad.net/noobslab/apps/ubuntu artful/main i386 Packages [1,572 B]
Get:7 http://ppa.launchpad.net/noobslab/apps/ubuntu artful/main amd64 Packages [1,560 B]
Get:8 http://ppa.launchpad.net/noobslab/apps/ubuntu artful/main Translation-en [1,160 B]
Fetched 19.7 kB in 4s (4,087 B/s)               
Reading package lists... Done

sudo apt-get upgarde :

arya@arya:~$ sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

apt policy playonlinux curl libcurl3 :

arya@arya:~$ apt policy playonlinux curl libcurl3
playonlinux:
  Installed: (none)
  Candidate: 4.2.12-1
  Version table:
     4.2.12-1 500
        500 http://archive.ubuntu.com/ubuntu artful/multiverse amd64 Packages
        500 http://archive.ubuntu.com/ubuntu artful/multiverse i386 Packages
curl:
  Installed: (none)
  Candidate: 7.55.1-1ubuntu2
  Version table:
     7.55.1-1ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu artful/main amd64 Packages
libcurl3:
  Installed: 7.55.1-1ubuntu2.3
  Candidate: 7.55.1-1ubuntu2.3
  Version table:
 *** 7.55.1-1ubuntu2.3 100
         100 /var/lib/dpkg/status
     7.55.1-1ubuntu2 500
        500 http://archive.ubuntu.com/ubuntu artful/main amd64 Packages
  • Install curl as suggested? – Rinzwind Feb 8 '18 at 20:56
  • I try to install it and it said this : The following packages have unmet dependencies: curl : Depends: libcurl3 (= 7.55.1-1ubuntu2) but 7.55.1-1ubuntu2.3 is to be installed E: Unable to correct problems, you have held broken packages. @Rinzwind – Arya Sadeghi Feb 8 '18 at 21:00
  • Please also add the output of apt policy playonlinux curl libcurl3 - and move that output from trying to install curl into the question as well. Thanks. – Byte Commander Feb 8 '18 at 21:12
  • @AryaSadeghi you installed something else that is related to another version of Ubuntu. Can you tell us what that is? You cannot mix packages from different releases of Ubuntu - they are incompatible. – Rinzwind Feb 8 '18 at 21:17
  • done... @ByteCommander – Arya Sadeghi Feb 8 '18 at 21:18
3

You have an incompatible version of libcurl3 installed on your system. Probably you had a PPA or other unofficial software source added at some point in the past which provided this.

The solution is to downgrade libcurl3 to the correct version matching the other packages from the official repositories:

sudo apt install libcurl3=7.55.1-1ubuntu2

After that, you should be able to install playonlinux, as its dependency curl will no longer be blocked by a conflicting dependency version.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.