0

I followed the instructions in the SANE daemon tutorial to set up a network scanner.

Everything should be set as needed. However, when I open xsane on a client PC (I tried more than one client, with the same result), the host saned denies access:

Feb  6 14:29:56 xxxxxxx systemd[1]: Started Scanner Service (xxx.xxx.xx.xxx:46488).
Feb  6 14:29:56 xxxxxxx saned[5122]: saned (AF-indep+IPv6) from sane-backends 1.0.26git starting up
Feb  6 14:29:56 xxxxxxx saned[5122]: check_host: access by remote host: localhost
Feb  6 14:29:56 xxxxxxx saned[5122]: init: access by host localhost denied
Feb  6 14:29:56 xxxxxxx saned[5122]: saned exiting

I'm puzzled here by the fact that the access request comes from 'localhost' instead of the client IP/name. If I indeed include localhost in the allowed IPs, the log changes into:

check_host: access by remote host: localhost
init: bad status=22 or procnum=6350304

I tried several things (add saned to lp and saned groups, modify saned@.service, define permission rules for saned), but nothing changes. Of course, the scanner works locally on the host. If, however, I add localhost both in saned.conf and in net.conf, I can connect to the scanner only locally, no second 'localhost' copy is detected by xsane (as mentioned in the tutorial for troubleshooting).

Do you have any idea?

1
  • I have the same problem and running bionic (64bit) with included 1.0.27-1... no chance to make my scanner (C460FW) running. any help appreciated, i checked all posts/manuals for this, something is really odd... the best post i found re this is askubuntu.com/questions/969238/… but also anything of this did not help. – Andi Fink May 11 '18 at 9:45
0

After several efforts, it seems that the solution came by upgrading sane-backends from 1.0.26git to 1.0.27git.

0

think I found the missing pieces: - package libusb-0.1-4 must be installed - /opt/smfp-common/scanner/lib/libsane-smfp.so.1.0.1 must have chmod a+x set

works like a charm now! now backend smfp is found for the network scanner

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.