I used Gparted to resize a ext4 partition but it fails. This is the command:

% resize2fs -p /dev/sdb5

resize2fs 1.42.13 (17-May-2015)

resize2fs: Filesystem has unsupported read-only feature(s) while trying to open /dev/sdb5 Couldn't find valid filesystem superblock.

I've been searching about this problem and I found similar issues in CentOS and Redhat for which it is recommended to use resize4fs (ext4). However this is not available for Ubuntu 16.04.

How could I tackle this problem?

  • 1
    Partition has to be unmounted. You cannot run from your working system, but need to use live installer's gparted or download the latest gparted ISO and use it.
    – oldfred
    Feb 7 '18 at 22:54
  • Using gparted from a recent live CD is the best answer I can think of too. Can you post it as an answer? I would, but I don't want to take credit from you. Feb 7 '18 at 23:05
  • There is no resize4fs. It appears that you are using a newer ext4 feature in which case, you need to use a newer release than 16.04 to resize it.
    – psusi
    Feb 8 '18 at 2:39
  • Are you root/did you use sudo ? Feb 8 '18 at 15:39

As suggested in the comments a recent gparted live CD solved my problem. I could resize the partition without problems using a live CD of gparted v0.30.0.

However my laptop did not boot after the resizing. The grub got destroyed!! I solved this with a live CD of systemrescueCd. I restored the grub using the solution 2 from here.


I encountered this same error because the partition was not mounted.

After creating a mount point and then mounting, resize2fs completed without error.

mkdir /temp-mount-point
mount /dev/sdb5 /temp-mount-point
resize2fs /dev/sdb5

resize2fs 1.42.13 (17-May-2015)
Filesystem at /dev/sdb5 is mounted on /temp-mount-point; on-line resizing required
old_desc_blocks = 1, new_desc_blocks = 699
The filesystem on /dev/sdb5 is now 1463818240 (4k) blocks long.


The following worked of me:

  • Download and build the latest version of e2fsprogs.
  • Replace the existing /usr/sbin/e2fsck and /usr/sbin/resize2fs - after making a backup of course.

This also eliminated the infamous "update e2fsck" issue as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.