0

I have Asus ROG STRIX Z370-E GAMING motherboard with wireless card built in (Realtek RTL8822BE). I'm running Mint 18.3 x64 and the system doesn't seem to "see" the device. There are no linux drivers on producer's website, I've tried installing them via ndiswrapper. Apparently the driver is installed correctly and device is recognized, but I still don't see the option to connect to wireless network anywhere.

$ndsiwrapper -l
netrtwlane : driver installed
device (10EC:B822) present

System details shows the following in the network section:

Network:   Card-1: Intel Ethernet Connection (2) I219-V
           driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6 chip-ID: 8086:15b8
           IF: enp0s31f6 state: down mac: <filter>
           Card-2: Realtek Device b822 port: d000 bus-ID: 04:00.0 chip-ID: 10ec:b822
       IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A

Any ideas who should I proceed to get the wireless module to work?

closed as off-topic by David Foerster, Kevin Bowen, Fabby, Thomas, Eric Carvalho Sep 4 '18 at 13:43

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This is not about Ubuntu. Questions about other Linux distributions can be asked on Unix & Linux, those about Windows on Super User, those about Apple products on Ask Different and generic programming questions on Stack Overflow." – David Foerster, Kevin Bowen, Fabby, Thomas, Eric Carvalho
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    Mint is off-topic here, but I posted an answer rather than voting to close, because the solution is the same for Ubuntu. I hope our Ubuntu friends will search for and find this answer. – chili555 Feb 7 '18 at 21:23
  • I'm aware that this is Ubuntu forum, but since Mint is based on Ubuntu I thought I'll get the highest chances for an answer here :). – rufus1530 Feb 10 '18 at 15:42
  • @rufus1530 - it's been brought to my attention that the pesky rtl8822be should work out of the box in 18.04. It's very possible that it does. It'd be great if it does, in fact. If you get the chance to test an Ubuntu 18.04 Live USB on your machine then it'd be good to know if it's still being problematic. I can then stop my crusade about the rtl8822be and focus on the rtl8821ce ;) – pHeLiOn Sep 4 '18 at 20:05
  • @pHeLiOn - you're correct, the rtl8822be works out of the box in 18.04. 'How' it works is a topic for different thread through :). But yeah, you can consider this problem solved, thanks! – rufus1530 Sep 5 '18 at 9:18
  • @rufus1530 - that's great news! Really appreciate you testing that & that'll help troubleshooting any further rtl8822be issues. – pHeLiOn Sep 5 '18 at 9:26
5

First, I'd remove ndiswrapper:

sudo apt-get purge ndiswrapper*

Next, with a temporary working internet connection, do:

wget https://github.com/lwfinger/rtlwifi_new/archive/extended.zip
unzip extended.zip
cd rtlwifi_new-extended
make
sudo make install
sudo modprobe rtl8822be

If, after the 'make' step, you have errors, please post them here. Warnings are probably alright.

EDIT: You have compiled the driver for your current running kernel only. When Update Manager installs a later one, also known as linux-image, after the requested reboot, re-compile:

cd ~/rtlwifi_new-extended
make clean
make
sudo make install
sudo modprobe rtl8822be
  • Please see my edit above in a few moments. Glad it's working. – chili555 Feb 10 '18 at 15:53
  • @chili555 The return I get from ‘make’ is make -C /lib/modules/4.13.0-37-generic/build M=/home/rowand/rtlwifi_new-extended modules make[1]: Entering directory '/usr/src/linux-headers-4.13.0-37-generic' arch/x86/Makefile:153: CONFIG_X86_X32 enabled but no binutils support ./scripts/gcc-version.sh: line 25: gcc: command not found ./scripts/gcc-version.sh: line 26: gcc: command not found make[1]: gcc: Command not found make[1]: gcc: Command not found make[1]: gcc: Command not found make[1]: gcc: Command not found – Andrew Conley Mar 21 '18 at 16:11
  • make[1]: gcc: Command not found CC [M] /home/rowand/rtlwifi_new-extended/base.o /bin/sh: 1: gcc: not found scripts/Makefile.build:308: recipe for target '/home/rowand/rtlwifi_new-extended/base.o' failed make[2]: *** [/home/rowand/rtlwifi_new-extended/base.o] Error 127 Makefile:1550: recipe for target '_module_/home/rowand/rtlwifi_new-extended' failed make[1]: *** [_module_/home/rowand/rtlwifi_new-extended] Error 2 make[1]: Leaving directory '/usr/src/linux-headers-4.13.0-37-generic' Makefile:87: recipe for target 'all' failed make: *** [all] Error 2 – Andrew Conley Mar 21 '18 at 16:11
  • @AndrewConley Please install the package build-essential and try again. If that doesn't fix it, start your own new question and we'll help you. – chili555 Mar 21 '18 at 16:53
  • @chili555 That worked. Many thanks! I am using a Thinkpad E580 in case that helps anyone find the answer they need. Also, is it worth editing the title of the question or mentioning in the answer that this relates to the Realtek rtl8822be? – Andrew Conley Mar 22 '18 at 0:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.