0

Both Windows and Ubuntu are installed on my computer(a Dell Inspiron laptop). Windows came pre-installed, and I installed Ubuntu myself.

Both worked fine until today, when I turned off the laptop after a bit of browsing. Until then everything worked fine. When I powered the machine back on today, a black screen showed 'No bootable device found'. The grub menu has completely vanished, along with Ubuntu. I played some time with boot settings and finally loaded default factory settings.

Now it just boot into Windows, not even a sign of Ubuntu. I tried to repair grub by following this guidebut it returned 'EFI device could not be found'. Can someone help me? Any help would be appreciated. Please excuse my English.

2
  • 1
    May be best to see details, you can run from your Ubuntu live installer or any working install, use ppa version not older Boot-Repair ISO: Post the link to the Create BootInfo summary report. Is part of Boot-Repair: help.ubuntu.com/community/Boot-Info and: sourceforge.net/p/boot-repair/home/Home – oldfred Feb 7 '18 at 15:25
  • "finally loaded default factory settings" sounds like you probably restored the machine's factory-default configuration from the recovery partition, which likely erased your Ubuntu installation. :( – Alex Feb 7 '18 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.