2

In a bit of a problem here. I installed a proprietary nvidia driver on my Ubuntu 16.04 on the Virtual Box. After I have do so, I was not able to get past the login screen. I would input my password, it would look as if it is going to give me the desktop screen but then it would go back to the start screen again and ask me for login details.

I followed the steps here to mess with the grub file through the command line (upstart): 12.04.3 can start only after I press "resume" in rescue mode (every boot) - problem with Nvidia driver

After adding nomodeset and running the update-grub - problem was not solved. So I removed quite splash and now I get the UEFI screen. No idea what that is. And now I am stuck....

NOTE: Fixed the UEFI issue. I had a tick box ticked in the VB settings. But still cannot get past the login screen. Easy solution: is to delete the nvidia driver. But I really do not want to. As I believe my sound stutter on videos is due to absence of the driver.

  • You don’t need drivers for your actual graphics card inside VirtualBox since it provides the guest with its own virtual graphics card. You should rather check your VirtualBox settings. – Melebius Feb 7 '18 at 13:21
  • working now. I had to purge nvidia: sudo apt-get purge nvidia* – i squared - Keep it Real Feb 7 '18 at 13:26
  • but the sound stutter persists..... – i squared - Keep it Real Feb 7 '18 at 13:27
0

The proprietary nvidia driver here won't help unless you're using some form of PCIe forwarding (probably not unless you explicitly enabled this support in your host BIOS and have more than one graphics device.)

Instead, you should install the virtualbox guest additions in the VM, as it will provide better integration with the VM hardware, it's available in the package virtualbox-guest-dkms and will install everything into the kernel for you. The guest graphics for X11 is in virtualbox-guest-x11. Just sudo apt install them.

For your stutter issue, I would check the audio device being emulated, something like the audio settings in virtualbox

Try different audio controllers, some may perform better than others, and make sure your host audio driver is on the one you're using. (Pulse by default.)

  • host audio driver is not pulse – i squared - Keep it Real Feb 7 '18 at 15:31
  • @isquared-KeepitReal Oh, sorry, pulse is the default for an Ubuntu host. If you have other options besides the default on windows it might be worth trying those as well. – Robobenklein Feb 7 '18 at 15:33
  • Windows audio for driver. And then soundblast (gives no sound), Intel hd audio -> soft hissing and stuttering, ich ac97-> less frequent disturbances but worse than Intel hd audio – i squared - Keep it Real Feb 7 '18 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.