5

I have been trying to launch Lords-a-war! 0.3.0.2 now for a while. It installs fine and appears in the launcher but doesn't start, doesn't throw an error or even shows up in the task manager, any ideas?

I'm using Ubuntu Gnome 16.04.3

I was on Kubuntu 16.04 before that. It didn't work there either (Didn't change the interface because of it tho).

When launching from the terminal, I get this error:

(process:24804): glibmm-CRITICAL **: Glib::ObjectBase* Glib::wrap_create_new_wrapper_for_interface(GObject*, GType): assertion 'wrap_func_table != nullptr' failed
(process:24804): GLib-GObject-CRITICAL **: g_object_set_qdata_full: assertion 'quark > 0' failed
(process:24804): glibmm-CRITICAL **: Glib::ObjectBase* Glib::wrap_create_new_wrapper_for_interface(GObject*, GType): assertion 'wrap_func_table != nullptr' failed
(process:24804): GLib-GObject-CRITICAL **: g_object_set_qdata_full: assertion 'quark > 0' failed
(process:24804): glibmm-CRITICAL **: Glib::ObjectBase* Glib::wrap_create_new_wrapper_for_interface(GObject*, GType): assertion 'wrap_func_table != nullptr' failed
(process:24804): GLib-GObject-CRITICAL **: g_object_set_qdata_full: assertion 'quark > 0' failed
(process:24804): glibmm-CRITICAL **: Glib::ObjectBase* Glib::wrap_create_new_wrapper_for_interface(GObject*, GType): assertion 'wrap_func_table != nullptr' failed
(process:24804): GLib-GObject-CRITICAL **: g_object_set_qdata_full: assertion 'quark > 0' failed
(process:24804): glibmm-CRITICAL **: Glib::ObjectBase* Glib::wrap_create_new_wrapper_for_interface(GObject*, GType): assertion 'wrap_func_table != nullptr' failed
(process:24804): GLib-GObject-CRITICAL **: g_object_set_qdata_full: assertion 'quark > 0' failed
(process:24804): glibmm-CRITICAL **: Glib::ObjectBase* Glib::wrap_create_new_wrapper_for_interface(GObject*, GType): assertion 'wrap_func_table != nullptr' failed
(process:24804): GLib-GObject-CRITICAL **: g_object_set_qdata_full: assertion 'quark > 0' failed Segmentation fault

I've found a similar question on Ubuntu 14.04, that is not solved, and doesn't provide an actual solution. It can be found here.

6
  • 1
    Have you tried launching the game from a terminal? Ctrl-Alt-T to open a terminal, then simply type "lordsawar" (without the quotes) and press Enter. If this works, it may be the launcher that is broken. If it doesn't, the terminal output may give some clues as to what went wrong. Anecdotally, I just tried installing it on my Ubuntu 17.10 (Xorg) and it starts fine, both from launcher and terminal. – anlag Feb 7 '18 at 13:00
  • Yes, I just did and I've got an error, I'll update the question with the error infortmation. – Muaad ElSharif Feb 7 '18 at 13:37
  • 1
    I agree, unfortunately I didn't (don't) have the reputation on this site to comment on someone else's question, so it was either an imperfect answer or not contributing towards a solution at all. I thought of mentioning this in my reply, but it seemed like even more off-topic content so I decided against. Regardless, since the OP has now updated his question with terminal output, my (non-)answer can be deleted. – anlag Feb 7 '18 at 14:27
  • @MuaadElSharif Oddly enough Xenial Xerus 16.04 actually has lordsawar 0.3.0 in the repository but you are running an older version: 0.2.3? Could be a library mismatch if you have used a package from a different version of Ubuntu. Package + Ubuntu versions here: packages.ubuntu.com/… – andrew.46 Feb 18 '18 at 4:59
  • @andrew.46 I edited the question, I was running 0.3.02 from the store, but I'll try downloading the 17.10. – Muaad ElSharif Feb 18 '18 at 10:55
1

My suspicion is that you have installed a package that is not built for Xenial Xerus 16.04. Best thing to do is to build your own package of Lords-A-War and build the very latest pre-release version 0.3.2-pre3 while you are at it!

The following commands set up a build environment, downloads, compiles and installs this pre-release version on Xenial Xerus 16.04:

1. Install some dependencies and build tools:

sudo apt-get install build-essential checkinstall automake \
autoconf libtool m4 autotools-dev autopoint g++ libsigc++-2.0-dev \
libglibmm-2.4-dev libgtkmm-3.0-dev gettext git libgstreamermm-1.0-dev \
intltool libarchive-dev libxslt1-dev libxml++2.6-dev

2. Make a build directory and download the source:

mkdir ~/lordsawar_build && cd ~/lordsawar_build && \
wget http://download.savannah.gnu.org/releases/lordsawar/lordsawar-0.3.2-pre3.tar.gz

3. Extract the source, compile and install:

cd ~/lordsawar_build && \
tar xvf lordsawar-0.3.2-pre3.tar.gz && cd lordsawar-0.3.2-pre3 && \
./configure && make -j 2 && \
sudo checkinstall -D --install=yes --fstrans=no --pakdir "$HOME/lordsawar_build" \
   --pkgname lordsawar --backup=no --deldoc=yes --deldesc=yes --delspec=yes --default \
   --pkgversion "0.3.2-pre3"

4. Test it out!!

Works well on my Xenial Xerus system:

enter image description here

And hopefully on your system as well :)

2
  • the command resulted in broken dependancies, didn't work. The following packages have unmet dependencies: libgtkmm-3.0-dev : Depends: libgtk-3-dev (>= 3.18.0) but it is not going to be installed E: Unable to correct problems, you have held broken packages. – Muaad ElSharif Feb 21 '18 at 12:31
  • 2
    @MuaadElSharif This technique works well on a fresh VM of Xenial. My suspicion is that your system has a few installations from PPAs or from other versions of Ubuntu which have altered some key Xenial files. If a clean install is not an option there are some tips here for fixing such a system: unix.stackexchange.com/questions/389156/… – andrew.46 Feb 21 '18 at 21:19
1

Bad news.

Uninstalling a variant of Ubuntu can/will mess up your install. I ran Kubuntu and swapped back to Ubuntu, and voila, whole system broken. Also, I was missing Ubuntu dependencies.

The Solution(s)

1)

Distro Upgrade and Upgrade:

  1. Install the latest updates via Ubuntu Software Center, or use sudo apt-get dist-upgrade
  2. Install the upgrades for packages: sudo apt-get upgrade

2)

Reinstall OS: Install the OS again. Use another PC to re-create a Ubuntu live USB/DVD. Back up data onto external drive or cloud storage if needed. Make sure to wipe off OS drive, when installing.

This helped me.

EDIT: According to another answer's comment (by you), you are missing dependencies. Let's see what you need. You need: libgtk-3-dev so sudo apt-get install libgtk-3-dev. Now, try running the dependency install: sudo apt-get install build-essential checkinstall automake \ autoconf libtool m4 autotools-dev autopoint g++ libsigc++-2.0-dev \ libglibmm-2.4-dev libgtkmm-3.0-dev gettext git libgstreamermm-1.0-dev \ intltool libarchive-dev libxslt1-dev libxml++2.6-dev and run the build.

5
  • SOURCES: My brain and Google – Tyler Lawrence Feb 23 '18 at 22:36
  • While your answer is very logical, I have another computer with Ubuntu Gnome native installed on it, same error. I did the update and upgrade, I have no issues in general but I'd rule out the distro thing. – Muaad ElSharif Feb 24 '18 at 13:05
  • No one managed to solve it, no one gets the bounty.. – Muaad ElSharif Feb 25 '18 at 0:04
  • 1
    @MuaadElSharif Fair enough, but next time you have a clean installation try my answer and you should get the latest version of the game running well enough... – andrew.46 Feb 25 '18 at 0:49
  • 1
    Edited answer based on comment on @andrew.46 's answer. – Tyler Lawrence Feb 25 '18 at 1:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.