1

I am running XFCE through crouton on my Chromebook. I wanted to install Steam but I'm having a problem. It says Steam needs to install libgl1-mesa-dri:i386, libgl1-mesa-glx:i386 and libc6:i386. And each time I try to run it, it says You are missing the following 32-bit libraries, and Steam may not run: libc.so.6.

Can anyone help me out with my problem?

1

libc6.so.6 is in the package libc6-i386, so install that package too.


The libc6.so.6 you are missing is the 32 bit version from /lib32/libc6.so.6. There is another 64 bit version in /lib/x86_64-linux-gnu/libc.so.6 but that's not the one you need for Steam. After installing all the missing 32 bit libraries steam needs, you will still need the 32 bit loader, which is also in the libc6-i386 package. Once the 32 bit loader is present, the ldd script run on your Steam executable will produce output listing the required libraries, and which are missing.
The 32 bit packages may be distinguished from the 64 bit versions by adding ":i386" to the package name when installing, e.g.:

sudo apt-get install libgl1-mesa-dri:i386  

The libc6:i386 and the libc6-386 packages are probably the same. Some people suggest:

sudo dpkg --add-architecture i386  
sudo apt-get update  

commands, but I've never had to do that.

  • 1
    I already have libc6.so.6, for some reason it still wont work – dunkpig Feb 6 '18 at 22:09
  • How would I install the missing 32 bit libraries that it needs? Sorry I am new to linex/ubuntu. – dunkpig Feb 7 '18 at 13:41
0

Running the following commands fixed the issue for me:

sudo dpkg --add-architecture i386  
sudo apt-get update* 
0

Here is what I had to do for my Ubuntu 18.04 installation, and follow this closely.

Firstly, as others mentioned, run the following:

sudo dpkg --add-architecture i386  
sudo apt-get update

Then, go to this page and download libnvidia-gl-390_390.48-0ubuntu3_i386.deb: https://packages.ubuntu.com/bionic/i386/libnvidia-gl-390/download

Next, cd to the download directory and run the following:

sudo dpkg -i libnvidia-gl-390_390.48-0ubuntu3_i386.deb
sudo apt install -f
sudo dpkg -i libnvidia-gl-390_390.48-0ubuntu3_i386.deb

And all should be right with the world; you are now ready to Steam!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.