0

I recently downloaded Virtualbox. These are the steps I took:

  1. I first went to VirtualBox download and downloaded the right version for my computer and OS (Ubuntu 16.04 64bit).
  2. I opened up my terminal and went into the Downloads directory. I continued to type ls to open what was in my downloads file. The only thing in there was the Virtualbox file
  3. I copied the file link and before I pasted it I typed "sudo dpkg -i" and the copied the link after.

This finally got everything installed. Finally I opened up Virtualbox and I made my windows virtual machine correctly, and I tried to start it, but it came up with a Error in suplibOsInit. I read this and it says I need to reinstall the kernel module by executing /sbin/vboxconfig Could someone please tell me how to fix this problem.

After running the 'sudo apt list virtual* the output was:

Listing... Done
virtualbox/xenial-updates 5.0.40-dfsg-0ubuntu1.16.04.2 amd64
virtualbox-5.2/now 5.2.6-120293~Ubuntu~xenial amd64 [installed,local]
virtualbox-dbg/xenial-updates 5.0.18-dfsg-2ubuntu1 amd64
virtualbox-dkms/xenial-updates,xenial-updates 5.0.40-dfsg-0ubuntu1.16.04.2 all
virtualbox-ext-pack/xenial-updates,xenial-updates 5.0.40-0ubuntu1.16.04.1 all
virtualbox-guest-additions-iso/xenial-updates,xenial-updates 5.0.40-0ubuntu1.16.04.1 all
virtualbox-guest-dkms/xenial-updates,xenial-updates 5.0.40-dfsg-0ubuntu1.16.04.2 all
virtualbox-guest-dkms-hwe/xenial-updates,xenial-updates 5.0.40-dfsg-0ubuntu1.16.04.1~16.04.4 all
virtualbox-guest-source/xenial-updates,xenial-updates 5.0.40-dfsg-0ubuntu1.16.04.2 all
virtualbox-guest-source-hwe/xenial-updates,xenial-updates 5.0.40-dfsg-0ubuntu1.16.04.1~16.04.4 all
virtualbox-guest-utils/xenial-updates 5.0.40-dfsg-0ubuntu1.16.04.2 amd64
virtualbox-guest-utils-hwe/xenial-updates 5.0.40-dfsg-0ubuntu1.16.04.1~16.04.4 amd64
virtualbox-guest-x11/xenial-updates 5.0.40-dfsg-0ubuntu1.16.04.2 amd64
virtualbox-guest-x11-hwe/xenial-updates 5.0.40-dfsg-0ubuntu1.16.04.1~16.04.4 amd64
virtualbox-qt/xenial-updates,now 5.0.40-dfsg-0ubuntu1.16.04.2 amd64 [residual-config]
virtualbox-source/xenial-updates,xenial-updates 5.0.40-dfsg-0ubuntu1.16.04.2 all
virtualbricks/xenial,xenial 1.0.2-1 all
virtualenv/xenial-updates,xenial-updates 15.0.1+ds-3ubuntu1 all
virtualenv-clone/xenial,xenial 0.2.5-1 all
virtualenvwrapper/xenial,xenial 4.3.1-2 all
virtualjaguar/xenial 2.1.2-2 amd64
19
  • I may have read your question backwards when I answered earlier on your question - what is the host operating system that you are using? Feb 7, 2018 at 13:44
  • If I understand your question right, I have Ubuntu 16.04 (64 bit) and I downloaded the Virtualbox AMD64 under Ubuntu 16.04 ("Xenial") If this does not answer your question, please direct me on how to find my host operating system.
    – JWAVA
    Feb 7, 2018 at 15:04
  • I was a little confused by your statement that you 'ran it as root' - root is generally disabled in Ubuntu systems, and sudo is used to run commands with the root permissions. I'd like to ask you to run two commands, to make sure some needed elements are present on your system. The first is uname -a to we can tell what kernel you are using, and the second is apt list build-essential, linux-headers-$(uname -r) to show system components required to compile some of the vbox modules are present. Feb 7, 2018 at 15:18
  • Additionally, if you could run apt list virtual* that would help - you can copy and paste the output of these commands into your question.... Feb 7, 2018 at 15:21
  • These are my results after running the commands: After I ran 'uname -a' Linux ASUS 4.13.0-32-generic #35~16.04.1-Ubuntu SMP Thu Jan 25 10:13:43 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux After I ran 'sudo apt list build-essential Listing... Done build-essential/xenial,now 12.1ubuntu2 amd64 [installed] jwava@ASUS:~$ sudo apt list build-essential, linux-headers he result after I ran 'sudo apt list build-essential, linux-headers-$(uname -r)' Listing... Done linux-headers-4.13.0-32-generic/xenial-updates,xenial-security,now 4.13.0-32.35~16.04.1 amd64 [installed,automatic]
    – JWAVA
    Feb 7, 2018 at 15:34

1 Answer 1

0

This is a pretty easy process:

Open a terminal window (press ctrl+alt+t)

Enter the command

sudo /sbin/vboxconfig

It takes a few minutes to finish

Enter the command exit to close the terminal window

1
  • I did the command line and after a few minutes I got this response "There were problems setting up VirtualBox. To re-start the set-up process, run /sbin/vboxconfig as root. So I ran this code again as root and the same error popped up
    – JWAVA
    Feb 7, 2018 at 1:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .