I have just installed PyCharm 2017.3.3 and I am trying to run a project written in python 3 but it doesn't run. I have checked the setting page it has only Python 2.7 interpreter. How can I upgrade the interpreter to Python 3.x.

enter image description here

I have checked the official PyCahrm

  • What version of Ubuntu? Have you already checked this page in the PyCharm help? – wjandrea Feb 6 '18 at 20:04

First locate your interpreter on your Ubuntu system, then Try these steps:

  1. From the file menu click or select settings:

enter image description here

  1. From left pane select project name, then on the right click on project interpreter

enter image description here

  1. On the right click on the project interpreter drop down arrow and choose show all from the options there.

enter image description here

  1. On the dialogue box that appears click on the + button on the right then click on Add Local text that will appear.

enter image description here

  1. In the Add local interpreter dialogue box that appears select System Interpreter then click on the three dots to the right and navigate to your python location mine is usr/bin/python3.5. And with that you should have your project use that python version.

enter image description here

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.