0

How do I setup Multi Monitors?

Ultimately I want to use Multi-Monitor. Initially keen to try to use HDMI, for the purpose of sending Audio to my monitor (3.5mm causes noise)

Here is my setup and What I have done:

Motherboard: ASRock Z370 Gaming-ITX/ac 1x Display Port, 1x HDMI, 1x Thunderbolt (USB-C) with Intel HD/UHD Graphics OS: Ubuntu 16.04 Installed and ran: Intel Graphics Update Tool for Linux* Monitor: 4K Philips with 2xDP and 2xHDMI

Day 1 - Ubuntu out of the box did not support my Monitor Size (everything was oblong), there was only 1 resolution in settings, not sure if HDMI was working. I did mess with the xrandr a little, hopefully no damage done there, no change, no multi-monitor, stil oblong. I found the app for my Intel Graphics, so installed the Intel Update Tool, ran it and voila, I have 4K option in settings,it works. However HDMI out does not work by itself, nor is there multiple monitor appearing in settings.

I have tested cable and Montiors HDMI In from a windows machine, monitor is all good.

I only get 1 res. option in display settings, as seen in the pic. Display Settings

How is Multi Monitor setup?

  • I was able to get HDMI working by itself, by activating it in the Bios. Still hope one day to use Multi Monitor. Reason I wanted HDMI initially was to get sound over HDMI, but that didn't work either. Will post another about that, but don't hold much hope. – NZ Dev Feb 8 '18 at 9:55
2

I recently built a system around an ASRock Z370M-ITX/ac and was able to get HDMI audio working after some debugging. I am not using multi-monitor so I don't know if I can help you there, but it is worth a shot and may at least get audio working.

In my case, HDMI audio was not working because the i915 graphics driver failed to properly load and register its capabilities (including its audio component) with the Linux kernel. There are a number of different reasons why the i915 driver might fail to load, and the driver was not giving any error messages. However, later in the boot process, the sound driver (snd_hda_intel in my case) was giving the following error:

snd_hda_intel 0000:00:1f.3: failed to add i915 component master (-19)

If you are getting this error, take a look at my other answer here and see if that helps. Or tl;dr and add the following line to /etc/modprobe.d/modesetting.conf:

options i915 modeset=1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.