2

Running do-release-upgrade, it gets stuck on reading cache

Did a sudo apt-get dist-upgrade before, any ideas?

Edit: Rebooted and decided to let it keep going. Still stuck on reading cache. Search results turning up nothing, can't find anyone that's had a similar problem.

8
  • 'Reading Cache' occurs several times. Which time is this? What happend immediately previous?
    – user535733
    Feb 5 '18 at 15:26
  • First one that comes up. Here's a screenshot of where i'm at: i.imgur.com/vqhXQfc.png. Feb 5 '18 at 15:27
  • Can you specify more information? For examaple the apt log. CLI: cat var/log/apt/history.log GUI: gedit var/log/apt/history.log Feb 5 '18 at 15:27
  • Cancel and start again. Release upgrades can be safely cancelled at any time during calculation and downloading. Release-upgrades must not be cancelled later -- during package installation and configuration.
    – user535733
    Feb 5 '18 at 15:29
  • I've interrupted it more than a few times. Rebooted too. It never gets past it. Feb 5 '18 at 15:30
1

I had the same issue.

I also had lots of

NMI watchdog: BUG: soft lockup - CPU#0 stuck for 22s!

errors in the system logs.

This answer on the Canonical bug tracker: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1530405/comments/75 helped me solve the issue

I switched from nouveau to nvidia drivers, all CPU stuck issues disapeared and the do-release-upgrade worked.

0

So, after messing around since yesterday morning with this, I discovered that all I had to do was run do-release-upgrade with the -p flag for it to proceed past reading cache. Idk why, but it worked and i'm up and running now. If anyone has this problem in the future, try that.

0

To address another potential cause, I had the exact symptoms posted in the question and for me it was caused by a customer kernel I was using. Once I switched back to the stock kernel I was able to get passed the reading cache step.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.