I can't get the Citrix Receiver to work on Ubuntu 17.10. (SSL connection couldn't be established)

I tried different versions and copying the certificates from Mozilla as described here and here and ran ctx_rehash. Another answer suggests to convert a .crt file to .pem.

It's not clear to me though which file is meant and how to get it. I connected to citrix via browser (which works), exported the certificate from the page info/security, converted it to .pem and rehashed. Doesn't work though


I'm having the same problem. And also tried to copy the certificates to /opt/Citrix/ICAClient/keystore/cacerts. I know the certificates work because I need them for browsing the internet (corporate firewall). Firefox and Chromium accept the certificates. Using openssl I found out that the certificates were already in pem format.

When making a connection to the Citrix storefront web page, I don't have a problem. The session starts fine.


The line below fixed it for me.

$ sudo c_rehash /opt/Citrix/ICAClient/keystore/cacerts/

  • 1
    OP indicated they rehashed without success. – Thomas Ward Feb 9 '18 at 17:18

I managed to connect by exporting the certificate manually from the browser:

  • go to the citrix site
  • view certificate
  • export the certificate. the correct one is one above the actual adress
  • convert from .crt to .pem
  • rehash

You should simply re-use the certificates already installed with the ca-certificates package, e.g.

$ cd /opt/Citrix/ICAClient/keystore/
$ sudo rm -r cacerts
$ sudo ln -s /etc/ssl/certs cacerts

No conversion and rehashing needed.

See Citrix receiver 13.10 on Ubuntu 18.04.1 for background reading (and why this is safe).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.