1

How to disable Toggle Maximization State in VM Ubuntu 16.04.

I have tried to disable Toggle Maximization State by setting values in dconf database.

dconf load / << EOF 
[org/gnome/desktop/wm/keybindings]
toggle-maximized=['disabled']
EOF

And also tried on my VirtualBox 16.04 LTS has two Compiz profiles - unity and unity-lowgfx.

dconf load / << EOF 
[org/compiz/profiles/unity/plugins/core]
toggle-maximized=['disabled']
EOF

dconf load / << EOF 
[org/compiz/profiles/unity-lowgfx/plugins/core]
toggle-maximized=['disabled']
EOF

But issue not resolved yet. Please help me on this.

1

Disableg shortcuts from cli

To disable shortcuts in gsettings, usually the value should be set to [].

In this case, in a command:

gsettings set org.gnome.desktop.wm.keybindings toggle-maximized '[]'

GUI

As always, there is also a gui-alternative: dconf-editor, installed by:

sudo apt install dconf-editor

Subsequently, browse to the key, uncheck "Use default value" and set it to []

enter image description here

2
  • Followed your advice, but if I press (Alt + F10) key. It's opening status menu(indicator) on the top bar. I don't want to be open status menu , it should also disable . How to disable it? – Dinesh Feb 6 '18 at 8:07
  • @Dinesh Toggle maximized is disabled by this procedure though, but I can understand you don't want it to do anything at all. On a 16.04 VM / Unity, it indeed opens the menu. I am afraid it is a built-in shortcut in Unity, which cannot be disabled. The fact that it is in the oversight if you press <Super> indeed supports the impression. – Jacob Vlijm Feb 6 '18 at 8:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.