0

Got a Dell Inspiron 13 7000 Laptop, it had a windows 10 on it, I installed ubuntu alongside windows (which I had done several times before on other laptops without any problems) and the windos didnt start anymore. namely when I chose windows on grub, it went on a black screen, the laptop stayed on (with keyboard LEDs on) but only with that black screen without any words,etc.

I thought it must be windows's fault and left it, I worked with ubuntu after a few days the same happened with ubuntu: when I chose ubuntu in grub it went to a black screen blah blah blah... I again said it must be because of the windows so this time I formatted the entire hard disk and installed a fresh ubuntu... (the latest official 17.10 on this website) it worked for a few days (nearly one week which took me to install my favourite apps and customize everything) and today the same happened again!

when I try to boot ubuntu on recovery mode, choosing the option in grub leads to only two lines of codes. right after it says "loading initial ramdisk" it goes on the black screen with LEDs on keyboard on but nothing happes until I force turn off holding down the power key. is that a known issue? somebody else faced this? any workaround? it is really not a good choice to reinstall ubuntu each time and customize it gaain and download all the apps, bla bla bla... that is the only thing I know works for me now

forgot to say that even after this happened live usb can boot ubuntu from the usb but not from the hard disk

  • I experience the same on ubuntu 18.04! – AlKaef Aug 12 '18 at 10:35
  • I just boot-repair to fix that, use a live ubuntu, connect to internet, open a terminal (ctrl-alt-t) and type: sudo add-apt-repository ppa:yannubuntu/boot-repair then install boot-repair using: sudo apt install boot-repair then launch boot-repair fo to advanced options and try to fix the problem (I could do that by purging grub and reinstalling it with a nomodset option) – Masoud Borbor Aug 22 '18 at 9:27
  • My case was due to unsupported Ryzen APU on the default kernel. Kernel upgrade fixed it! – AlKaef Aug 31 '18 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.