0

After command

sudo lspci | grep Network

I got :

03:00.0 Network controller: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter (rev31)

There is good news, when getting to wireless Internet, the Internet works for 3 seconds, and everything

dmesg | grep ath : [ 15.728351] ath10k_pci 0000:03:00.0: pci irq msi oper_irq_mode 2 irq_mode 0 reset_mode 0 [ 17.203121] ath10k_pci 0000:03:00.0: qca9377 hw1.1 target 0x05020001 chip_id 0x003821ff sub 11ad:08a6 [ 17.203124] ath10k_pci 0000:03:00.0: kconfig debug 0 debugfs 1 tracing 1 dfs 0 testmode 0 [ 17.203803] ath10k_pci 0000:03:00.0: firmware ver WLAN.TF.1.0-00267-1 api 5 features ignore-otp crc32 79cea2c7 [ 17.311405] ath10k_pci 0000:03:00.0: board_file api 2 bmi_id N/A crc32 8aedfa4a [ 17.792926] ath10k_pci 0000:03:00.0: htt-ver 3.1 wmi-op 4 htt-op 3 cal otp max-sta 32 raw 0 hwcrypto 1 [ 17.799704] ath: EEPROM regdomain: 0x69 [ 17.799705] ath: EEPROM indicates we should expect a direct regpair map [ 17.799707] ath: Country alpha2 being used: 00 [ 17.799707] ath: Regpair used: 0x69 [ 18.417455] ath10k_pci 0000:03:00.0 wlp3s0: renamed from wlan0 [ 43.622615] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT/VHT due to WEP/TKIP use [ 43.622621] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP [ 43.622624] ath10k_pci 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP [ 110.998656] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 110.999122] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 115.692965] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT/VHT due to WEP/TKIP use [ 115.692971] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP [ 115.692976] ath10k_pci 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP [ 146.412246] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 146.412789] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 151.120259] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 151.120657] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 151.223030] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 151.223061] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 151.325403] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 151.325433] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 151.427722] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 151.427753] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 151.530021] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 151.530075] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 156.237895] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 156.238297] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 156.340260] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 156.340650] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 156.442552] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 156.442967] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 156.544962] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 156.545327] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 156.647677] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 156.647706] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 156.749978] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 156.750141] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 156.851988] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 156.852388] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 161.797292] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT/VHT due to WEP/TKIP use [ 161.797295] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP [ 161.797297] ath10k_pci 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP [ 215.741097] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT/VHT due to WEP/TKIP use [ 215.741101] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP [ 215.741104] ath10k_pci 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP [ 378.857011] ath10k_warn: 6 callbacks suppressed [ 378.857015] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 378.857468] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 401.268162] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT/VHT due to WEP/TKIP use [ 401.268167] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP [ 401.268171] ath10k_pci 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP [ 513.874327] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 518.517802] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT/VHT due to WEP/TKIP use [ 518.517807] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP [ 518.517809] ath10k_pci 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP [ 2626.082587] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 2639.549723] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT/VHT due to WEP/TKIP use [ 2639.549725] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP [ 2639.549725] ath10k_pci 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP [ 3082.058439] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT/VHT due to WEP/TKIP use [ 3082.058440] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP [ 3082.058441] ath10k_pci 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP [ 3086.904567] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT/VHT due to WEP/TKIP use [ 3086.904573] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP [ 3086.904576] ath10k_pci 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP [ 3188.174361] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT/VHT due to WEP/TKIP use [ 3188.174366] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP [ 3188.174368] ath10k_pci 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP [ 3222.883823] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT/VHT due to WEP/TKIP use [ 3222.883827] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP [ 3222.883830] ath10k_pci 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP [ 3264.781291] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 3268.875564] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 3268.876039] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 3273.529102] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT/VHT due to WEP/TKIP use [ 3273.529106] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP [ 3273.529108] ath10k_pci 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP [ 3613.002749] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT/VHT due to WEP/TKIP use [ 3613.002754] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP [ 3613.002757] ath10k_pci 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP [ 3887.981946] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT/VHT due to WEP/TKIP use [ 3887.981951] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP [ 3887.981955] ath10k_pci 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP [ 3991.242085] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT/VHT due to WEP/TKIP use [ 3991.242089] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP [ 3991.242092] ath10k_pci 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP [ 7682.051336] ath10k_pci 0000:03:00.0: no channel configured; ignoring frame(s)! [ 7686.691780] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT/VHT due to WEP/TKIP use [ 7686.691784] ath10k_pci 0000:03:00.0 wlp3s0: disabling HT as WMM/QoS is not supported by the AP [ 7686.691787] ath10k_pci 0000:03:00.0 wlp3s0: disabling VHT as WMM/QoS is not supported by the AP

rfkill list all 1: acer-wireless: Wireless LAN Soft blocked: no Hard blocked: no 2: acer-bluetooth: Bluetooth Soft blocked: no Hard blocked: no 3: phy0: Wireless LAN Soft blocked: no Hard blocked: no 4: hci0: Bluetooth Soft blocked: no Hard blocked: no

3
  • The driver ath10k_pci is already installed. If the wireless isn't working, then something else is wrong. Please edit your question to add the result of these terminal commands: rfkill list all and also: dmesg | grep ath.
    – chili555
    Feb 4 '18 at 16:32
  • @chili555 rfkill list all gave : no blocked all . Feb 4 '18 at 16:44
  • There is good news, when getting to wireless Internet, the Internet works for 3 seconds, and everything Feb 4 '18 at 16:49
0

Please see:

wlp3s0: disabling HT/VHT due to WEP/TKIP use

Please check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

sudo nano /etc/default/crda

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Any improvement?

EDIT: I cannot, in good conscience, suggest that anyone protect their wireless only with WEP as it is quite insecure: https://en.wikipedia.org/wiki/Wired_Equivalent_Privacy

In August 2001, Scott Fluhrer, Itsik Mantin, and Adi Shamir published a cryptanalysis of WEP that exploits the way the RC4 ciphers and IV are used in WEP, resulting in a passive attack that can recover the RC4 key after eavesdropping on the network. Depending on the amount of network traffic, and thus the number of packets available for inspection, a successful key recovery could take as little as one minute.

I suggest that you disable power saving in Network Manager. From the terminal:

sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*

Restart Network Manager:

sudo service network-manager restart

Finally, let’s be certain that you have the latest firmware; from the terminal:

sudo dpkg -s linux-firmware | grep Version

If your version is older than 1.169.2, then please do:

cd /tmp
wget http://mirrors.kernel.org/ubuntu/pool/main/l/linux-firmware/linux-firmware_1.169.2_all.deb
sudo dpkg -i linux*.deb

Reboot. Any improvement?

9

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.