0

I'm fairly new to file system's issues especially mounting a file system. I've poked around and found no optimal solution
I've had Kali Linux on a partition with EXT4 or EXT3 (I'm not sure) and Windows on another. In order to install Ubuntu on Kali's partition and format it to EXT4 in the process, I've moved my files to the Windows partition in a folder called temp. After installing Ubuntu, the folder is normally accessed and all of it content from Ubuntu, but on Windows 7 side I see an empty folder with a size of zero, even if that partition is a Windows' partition.

What happened there and how do make that folder accessible under Windows again??

  • Easier to click the down arrow than to give an answer, or even an explanation – user10089632 Feb 4 '18 at 15:50
  • Where exactly in the Windows folder hierarchy is temp? how did you copy your files to it? how do you mount/access them from Ubuntu? – steeldriver Feb 4 '18 at 16:06
  • @steeldriver, temp is at the root of the partition, I mean in Windows it's accessible at E:/temp. I've copied them when using Kali with the left click context menu copy to ... and I access them from Ubuntu you know when you click on files on the menu, you get the partitions at the bottom of the left menu, you click on it and you get the folders, temp is there, at the command line : it is in the path : /media/username/35842600BB0821/temp – user10089632 Feb 4 '18 at 18:11
  • 1
    You have to use @<username> in comments, otherwise I won't know that you said something to me. Sorry if my previous comments sounded condescending, but you made it sound like you had a firm grip on permissions ("Nope it's not about permissions nor hidden files"). Have a look at this answer for some sensible NTFS permissions or have a look at the Arch Wiki entry where they mention Linux compatible permissions. I hope this time I'll be able to help you, with your issue. – Robert Riedl Feb 5 '18 at 13:26
2

Judging by the discussion in the comments, it seems to me that this is an issue with the permissions set in Ubuntu, when copying/creating the content on the mounted NTFS partition - so your windows does not see the files.

A sensible(*) set of permissions would be the following entry in /etc/fstab

# Mount internal Windows partition with linux compatible permissions, i.e. 755 for directories (dmask=022) and 644 for files (fmask=133)
/dev/NTFS-partition  /mnt/windows  ntfs-3g uid=username,gid=users,dmask=022,fmask=133 0 2

You can edit your fstab with your favorite editor

sudo nano /etc/fstab

and modify it accordingly, with the correct paths for /dev and the mount point /mnt/.

The options uid=username,gid=users map the files and directories created under Linux on the NTFS partition to your Linux user.

While the options dmask=022,fmask=133 are the mask values (the bit values for the permissions that are not present) for the octal permission sets of "755" and "644" respectively.

dmask is for directory creation and fmaskfor file creation.

Here is a great Ubuntu wiki entry on the whole Linux permission system, which covers much more than I could in one answer here.

For ease of use to translate to octal permissions, you could use a converter homepage like this on the net

If you are content with your mount options you can either mount the partition with

sudo mount /mnt/your/windows/path

or, if it is already auto-mounted by ubuntu and giving you device busyerrors, you'd have to first unmount it via

sudo umount /dev/NTFS-partition

or simply reboot.

(*)Taken from the Arch Wiki entry on mounting NTFS partitions.

1

You might try creating what folders you need, from a Windows session, putting a dummy Windows-side-created file in each. Then go to Linux. You're not supposed to be able to write into a Windows partition unless you're running as the super-user, so sudo bash first, then copy the files one by one.

  • There are a lot of files, is it necessary to copy files one by one? – user10089632 Feb 4 '18 at 18:14
  • Thank you very much @daveboss! for me it worked by copying with right click then copy to entire folders as expected to a folder created under Windows. – user10089632 Feb 4 '18 at 18:34
  • Now I see a drawback of avi files normally played in Ubuntu have the sound stripped off after seconds of playing in Windows and I hope it's the only one. – user10089632 Feb 4 '18 at 21:02
  • Did you verify whether Windows screwed with the file, or did Windows not alter the file that played OK on Ubuntu, but just not play it right? – daveboss Feb 6 '18 at 3:14
  • @daeboss, It turns that I can play the file with Windows player, so it must be a problem of Vlc. Thank your insights are always in order. – user10089632 Feb 9 '18 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.