3

My problem is simple but I am almost one year with it, without a final solution. I have an Asus Laptop with Ubuntu 16.04, one year ago I made a reinstall of Ubuntu 16.04 (before that, my Ubuntu 16.04 works fine) and started the problems. My laptop freeze randomly, i can't use the mouse or keyboard, the screen is on but it's freeze, I can't shutdown my laptop. It can be two hours after turn it on, it can be six, it can be twelve; it happend making anything, when I update softwares, when I browse on internet, etc.

One month ago, I changed my Laptop's Cooler and then I formated the laptop and install a basic copy of Windows 10 for testing. I used it for a week and the problem didn't happend, so I formated again and install Ubuntu 16.04 (because I need it for work). Well, the problem is back. So I read all question here with this problem, but the anwsers doesn't work with me.

  • I tried to update kernel, from 4.13 to 4.15. The random freezes still. So I came back to 4.13.0-32-generic (my actual version).
  • I tried this solution with the grub and c-state. The random freezes still.
  • I tried to switch the drivers like this. The random freezes still.
  • I tried some patches of here (its hard understand what patch is useful, and follow the conversation). The random freezes still.
  • I made a Disk comprobation with GSmartControl, and my disk health is good.
  • I installed and run tlp. The random freezes still.
  • I updated intel microcode. The random freezes still.
  • I changed to kernel 4.4.0-112-generic (my actual kernel). The random still (random happend with 4.4.0-112-generic, 4.13.0-32-generic and 4.15).
  • I checked the hardware with a technician. The cooler is new (less than one month of use), and we didn't find problems on hardware. Freeze still.
  • T switch from Unity to Gnome. Random freeze still.

I really don't know, everything fails. This is my Laptop specifications like say "inxi -ACDMNSG":

System:    Host: xxxxx-U36SG Kernel: 4.4.0-112-generic x86_64 (64 bit)
           Desktop: Unity 7.4.0  Distro: Ubuntu 16.04 xenial
Machine:   Mobo: ASUSTeK model: U36SG v: 1.0
           Bios: American Megatrends v: U36SG.202 date: 10/19/2011
CPU:       Dual core Intel Core i5-2450M (-HT-MCP-) cache: 3072 KB 
           clock speeds: max: 3100 MHz 1: 2494 MHz 2: 2494 MHz 3: 2494 MHz
           4: 2494 MHz
Graphics:  Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
           Card-2: NVIDIA GF119M [GeForce 610M]
           Display Server: X.Org 1.19.5 driver: nvidia
           Resolution: 1366x768@60.02hz
           GLX Renderer: GeForce 610M/PCIe/SSE2
           GLX Version: 4.5.0 NVIDIA 384.111
Audio:     Card Intel 6 Series/C200 Series Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.13.0-32-generic
Network:   Card-1: Intel Centrino Wireless-N 1030 [Rainbow Peak]
           driver: iwlwifi
           Card-2: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet driver: atl1c
Drives:    HDD Total Size: 750.2GB (4.6% used)
           ID-1: /dev/sda model: ST9750423AS size: 750.2GB

Im going to appreciate any help with this.

EDIT: I tried tlp, update intel microcode and switch to kernel 4.4.0-112-generic. Random freezes still. Please, I need help with this.

EDIT2: I have one syslog more: https://gist.github.com/ibuioli/cb509b1417f28b4dbb90e2ae804cb08f Look at Feb 10 18:21 (last log before freeze, 18:28 was the reset). It say this:

Feb 10 18:21:15 ignacio-U36SG gnome-session[2524]: [10052:10091:0210/182115.522763:ERROR:connection_factory_impl.cc(381)] Failed to connect to MCS endpoint with error -106

EDIT3: When I did cat /var/log/syslog | grep -B9 Tainted I got this one time: https://gist.github.com/ibuioli/dc48e04816627c6a9768af62622324a2

EDIT4: The freezes still even with the recent updates, the freezes happens when I am using the laptop or event when is suspended. When the freeze happens, the Power Light still ON, the CPU Light is always OFF (not blink) and, sometimes, the Bloq-Mayus Light blinks steadily.

  • There are many people running kernel patches with a great deal of success: bugzilla.kernel.org/show_bug.cgi?id=109051 (Hit the End key and then scroll up for recent messages). – WinEunuuchs2Unix Feb 4 '18 at 15:48
  • Sorry, I ran some patches past week and the freezes problem still. I will test another, but my CPU is not on the Baytrail list. – ibuioli Feb 4 '18 at 16:02
  • I had problems of my own with 4.15 kernel so I would try 4.15.1 which came out yesterday. You can also try 4.14.17 because 4.14.xx is a five year Long Term Support (LTS) kernel. Many won't support you here unless you are on kernel 4.13.0-32 though as 4.14.xx and 4.15.xxare Linux kernels and not Ubuntu kernels. – WinEunuuchs2Unix Feb 4 '18 at 16:11
  • Ok I will back to 4.13.0-32, but they recommend the update to 4.15 in first place. – ibuioli Feb 4 '18 at 16:37
  • I'm just saying on this website most people will not offer help if you are running kernel 4.15. On the launchpad.net website developers often recommend trying 4.15 to see if the problem goes away. To file your bug report you should be running 4.13.0-32 (or the most current supported kernel) in the first place. Also make sure you are running thermald and tlp for general intel cpu smooth processing. Make sure your intel microcode is up-to-date. – WinEunuuchs2Unix Feb 4 '18 at 16:41
0

So I also had a problem similar to this. Why does my 16.04 install keep randomly freezing?

It had something to do with my wifi driver. I never go it worked out. I ended up just paying $10 for a new wifi card. (AR9280 AR5BHB92). I had a Intel 633ANHMW card running the same iwlwifi driver. Haven't had a problem since the change over.Run a cat /var/log/syslog | grep -A9 Tainted and see if you get any hits.

When you log in run tail -f /var/log/syslog in a separate terminal and see if anything suspicious populates while you are logged on.

EDIT: Correction try cat /var/log/syslog | grep -B9 Tainted . See if you have any warnings. It should tell you modules involved with the warning.

sorry for the answer but I cannot post comments yet

0

Consider this can be a hardware problem, even if you hadn't the same issue on Windows for a week. To me, it looks like a memory problem (RAM), in a way that your computer cannot even dump what is happening.

Try to run a full memory test - usually hardware vendors ship this in the computer, otherwise you can use the memtest from Grub boot screen as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.