2

Under (not-yet-installed) 17.10, I want a fixed number of (not dynamic) workspaces; whether they're presented horizontally or vertically I don't care. Under Ubuntu 16.10 I'm running now, I had do a system-settings tweak to enable multiple workspaces; then, a couple of gsettings commands to set the multiple-workspace grid size. But they worked on Unity, and Unity is gone. To select a workspace, I wrote a shellism that uses xdotool mousemove and xdotool click, under Ubuntu 16.10. When I ran Ubuntu 17.10 from the DVD, it couldn't install either xdotool or wmctrl.

Can I get the same workspace capability under Ubuntu 17.10? And, xdotool and wmctrl (or something else that does the same things)? I'll fix my shell file to do whatever it has to, for Ubuntu 17.10 (which it can detect by uname -r), but except for things I do once, after installation, I don't want to have to do anything with my fingers.

  • the obvious: 16.10 is EOL & insecure as its not patched - please upgrade. I downloaded & installed wmctrl (using only sudo apt install wmctrl) on Ubuntu 17.10 & it works normally (it was only tested with xorg login). I don't use xdotool, but it offered to be installed (with libxdo3 as req) – guiverc Feb 4 '18 at 1:31
  • The default login on Ubuntu 17.10 is Wayland. xdotool and wmctrl won't work properly or at all in Wayland. You'll need to login to an Xorg session. – DK Bose Feb 4 '18 at 6:15
1

I just installed wmctrl normally on Ubuntu 17.10 with no issues using

sudo apt install wmctrl

I tested it (using xorg) and it worked normally. (I use wmctrl on other machines)

I also sudo apt install xdotool and it offered to install (along with libxdo3 as a requirement) without any errors. The 'x' in the name implies to me it'll need xorg (not wayland) but I'd expect it to work too (I'm not familiar with this so I didn't install or test).

A few clicks (with tweak tool) and I had a static number of workspaces instead of the dynamic default, so you shouldn't have an issue.

Unity runs on 17.10 - but Unity is no longer a default, nor supported by Canonical; it's now a community project (like xubuntu, ubuntu-mate ...), and is being tested for 18.04 along with other DEsktops. Unity is NOT gone.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.