0

Here's my apt log:

Start-Date: 2018-02-04 03:36:24
Commandline: apt remove ^winep*
Requested-By: vivek-4313 (618153022)
Remove: winetricks:amd64 (0.0+20170101-1ubuntu2), wine64-development:amd64 (2.0-3ubuntu1), wine1.6:amd64 (1:1.8.4ubuntu1), wine1.6-amd64:amd64 (1:1.8.4ubuntu1), wine-development:amd64 (2.0-3ubuntu1), wine-stable:amd64 (2.0.4~zesty), wine64:amd64 (1.8.7-1ubuntu1), wine-stable-amd64:amd64 (2.0.4~zesty)
End-Date: 2018-02-04 03:36:28

Start-Date: 2018-02-04 03:37:48
Commandline: apt-get install --install-recommends winehq-stable
Requested-By: vivek-4313 (618153022)
Install: wine-stable:amd64 (2.0.4~zesty, automatic), winehq-stable:amd64 (2.0.4~zesty), wine-stable-amd64:amd64 (2.0.4~zesty, automatic)
Remove: wine1.6-i386:i386 (1:1.8.4ubuntu1)
End-Date: 2018-02-04 03:37:56

Start-Date: 2018-02-04 03:39:01
Commandline: apt remove ^winep*
Requested-By: vivek-4313 (618153022)
Remove: wine-stable:amd64 (2.0.4~zesty), winehq-stable:amd64 (2.0.4~zesty), wine-stable-amd64:amd64 (2.0.4~zesty)
End-Date: 2018-02-04 03:39:03

Start-Date: 2018-02-04 03:40:13
Commandline: apt-get install --install-recommends winehq-staging
Requested-By: vivek-4313 (618153022)
Install: wine-staging-i386:i386 (2.21.0~zesty, automatic), wine-staging:amd64 (2.21.0~zesty, automatic), wine-staging-amd64:amd64 (2.21.0~zesty, automatic), winehq-staging:amd64 (2.21.0~zesty)
Remove: unity8:amd64 (8.15+17.04.20170404.7-0ubuntu3), ffmpeg:amd64 (7:3.2.4-1build2), libav-tools:amd64 (7:3.2.4-1build2), qtdeclarative5-qtmir-plugin:amd64 (0.5.1+17.04.20170404-0ubuntu2), vdpau-va-driver:amd64 (0.7.4-6), va-driver-all:amd64 (1.7.3-2), unity8-desktop-session:amd64 (1.0.13+17.04.20170328.1-0ubuntu1), qtmir-desktop:amd64 (0.5.1+17.04.20170404-0ubuntu2), simple-scan:amd64 (3.24.0-0ubuntu1), at-spi2-core:amd64 (2.22.0-5ubuntu4), google-chrome-stable:amd64 (64.0.3282.140-1), gnome-orca:amd64 (3.22.2-2ubuntu1), ubuntu-desktop:amd64 (1.379), python3-pyatspi:amd64 (2.20.3+dfsg-1), gstreamer1.0-plugins-bad:amd64 (1.10.4-1ubuntu1), unity:amd64 (7.5.0+17.04.20170407.1-0ubuntu1), libatk-adaptor:amd64 (2.22.0-1ubuntu1), nautilus-share:amd64 (0.7.3-2ubuntu2), nautilus:amd64 (1:3.20.4-0ubuntu2), vlc:amd64 (2.2.4-14ubuntu2), libgail-3-0:amd64 (3.22.11-0ubuntu3), qtubuntu-desktop:amd64 (0.64+17.04.20170404-0ubuntu1), unity8-common:amd64 (8.15+17.04.20170404.7-0ubuntu3), vlc-plugin-base:amd64 (2.2.4-14ubuntu2), i965-va-driver:amd64 (1.7.3-1)
End-Date: 2018-02-04 03:40:32

I actually ran command to install wine staging version, but later realized to see many system packages got removed. My file manager (nautilus), Chrome, and so many were missing. I didn't restart the system yet, trying hard to install them back, but many packages couldn't be installed back due to dependencies errors.

Is there anyway to revert the packages removal? I'm unsure if the system will work if I restart, so your timely help is appreciated.

Update:

Tried re-installating packages, but:

vivek-4313@anonymous:~$ sudo apt install nautilus
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nautilus : Depends: libgail-3-0 (>= 3.0.0) but it is not going to be installed

Depends: nautilus-data (< 1:3.19) but 1:3.20.4-0ubuntu2 is to be installed
E: Unable to correct problems, you have held broken packages.
vivek-4313@anonymous:~$ sudo apt install nautilus-data
Reading package lists... Done
Building dependency tree
Reading state information... Done
nautilus-data is already the newest version (1:3.20.4-0ubuntu2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
vivek-4313@anonymous:~$ sudo apt install libgail-3-0
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgail-3-0 : Depends: libgtk-3-0 (= 3.18.9-1ubuntu3.3) but 3.22.11-0ubuntu3 is to be installed
E: Unable to correct problems, you have held broken packages.
vivek-4313@anonymous:~$

  • Look at serverfault.com/questions/380856/how-to-undo-apt-get-remove Maybe the second answer there might help. I copied your log and tested and it looks like it might actually reinstall all the apps that were removed. – Terrance Feb 3 '18 at 23:04
  • It returned all of these that have been removed: unity8 ffmpeg libav-tools qtdeclarative5-qtmir-plugin vdpau-va-driver va-driver-all unity8-desktop-session qtmir-desktop simple-scan at-spi2-core google-chrome-stable gnome-orca ubuntu-desktop python3-pyatspi gstreamer1.0-plugins-bad unity libatk-adaptor nautilus-share nautilus vlc libgail-3-0 qtubuntu-desktop unity8-common vlc-plugin-base i965-va-driver – Terrance Feb 3 '18 at 23:05
  • The problem is, my system had Ubuntu 16.04 installed and I've upgraded to 17.04 a month ago. Now, when I try to re-install, for example, say nautilus package, it says it depends on nautilus-data. But, when I try to install nautilus-data, it says nautilus-data version 1:3.20.4-0ubuntu2 is already present, but version < 1:3.19 is required. Most of the removed packages stuck at this point (I've recent package but old package is required as a dependency to removed package). How do I install a old version of nautilus-data (or any packages' old version)? – unix_root Feb 3 '18 at 23:07
  • 17.04 is no longer supported so the PPAs will no longer work. Try looking at askubuntu.com/questions/91815/… and see if maybe you can get something going without the need of a full reinstallation of your OS. – Terrance Feb 3 '18 at 23:09
  • 1
    In my last comment, it shows that 17.04 is no longer supported because it is EOL. Canonical no longer supports it, so any PPA that the system has will no longer have any applications in it, so that is why your reinstallation is failing. You will not be able to reinstall any of those apps unless you try to fix your PPAs first, or install a supported version. wiki.ubuntu.com/Releases – Terrance Feb 3 '18 at 23:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.