1

I'm running Kubuntu 17.10 (latest updates at the time of writing).

Everything works fine, but when I try switching from the Nvidia card to the Intel one (for energy reasons), the option - which seems available - in Nvidia X server settings just doesn't work.

Meaning I can click it, but it doesn't "stay selected", in lack of better words.

No syslog entry associated to the click.

A related issue, maybe: in Driver Manager, I if I activate the checkbox stating: Using Processor microcode firmware for Intel CPUs from intel-microcode and click Apply, the checkbox stays un-checked after refreshing.

This doesn't come with any useful syslog entry either, aside from DriverManager_DBus::devices START and DriverManager_DBus::devices END.

Hardware and drivers

  • KDE Plasma version 5.10.5
  • KDE Frameworks version 5.38.0
  • Qt version 5.9.1
  • Kernel version 4.13.0-32-generic
  • 64 bit
  • Output of lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)

01:00.0 VGA compatible controller: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] (rev a1)

  • Nvidia driver version: 384.111 (proprietary - I think?)

I've seen a lot of posts regarding Graphics cards and issues with various desktops, but haven't found any existing one that can help me.

TL;DR

How do I switch to Intel graphics for power saving in Kubuntu 17.10?

Edit

Switching ACPI off for PCI in the kernel parameters on boot (pci=noacpi) seems to force the Intel driver, but I suspect this won't play well with other PCI-related features, such as power metrics and even shutting down, rebooting, etc.

0

Found a very ugly solution - I hope there will be better answers.

It looks like package intel-microcode was not installed on Kubuntu by default for me (weird).

Once installed (sudo apt-get intel-microcode), I was able to set up NVIDIA X Server Settings to use the Intel card.

Now comes the ugliness.

  1. Since the power button applet in KDE ("ksmserver-logout-greeter") doesn't seem to like VGA device changes, I had to sudo reboot now from terminal, which somehow ended up shutting down the machine instead of rebooting
  2. Then, apparently something related to ACPI didn't quite work with my selected Intel card, so I had to restart again and parametrize the kernel with pci=noacpi

Now I am correctly using the Intel VGA device, but the steps to do so aren't particularly practical (let alone the possible implications of pci-noacpi).

So far, operations such as shutdown, reboot and logout seem to work with the Intel card selected.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.