1

Recently I've been trying to install Ubuntu alongside my Windows 10 installation. I've already shrinked my C: partition by 200GB, so there's plety of space. However, after mounting the Ubuntu iso on my USB drive (Using GPT mode for UEFI), it never shows up under the devices to boot from.

If I mount the USB again using the correct mode for the legacy BIOS and change the BIOS to legacy mode, I can boot from the USB without issues, but I won't be able to dual boot, since Windows itself is installed in UEFI mode.

What can I do?

0

You dont have to change the firmware settings to leagcy..

Just connect the bootable pen drive then enter into bios..there u will get boot menu -> enter into boot menu.

It will show all the bootable medias. In that two options for pen drive will appear one for legacy ,one for uefi ..

select uefi pendrive name option from that and then boot from it.

In this way your system will boot in uefi mode.

Hope it could help you

  • Thanks for the reply, but that's the thing, all the USB options are empty, it doesn't show either legacy or UEFI. – Leocano Feb 3 '18 at 20:04
  • Have u property created the image file on the usb .first test it on other pc ? – vipul jadhav Feb 4 '18 at 3:33
  • Yes, it worked flawlessly. I'm pretty sure the USB drive is not the problem. – Leocano Feb 4 '18 at 16:54
  • Have you disabled secure boot option in windows 10 .? – vipul jadhav Feb 4 '18 at 17:24
  • I've tried that, but it did not work. – Leocano Feb 4 '18 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.