0

i have ubuntu 17.10 currently installed and wine cannot be installed via sudo apt-get isntall winehq-stable, it is depending on wine-stable which in return depending on wine-stable-i386.

when i write down sudo apt-get install wine-stable-i386 it gives me a small list of uninstalled dependencies and if i want to install those it wants to remove ~300 packages from my system which some of them are core system elements

i searched and tried a lot of solutions online but with no use

0

Wine is in the Ubuntu software center(You may have to install it on some versions of Ubuntu. sudo apt-get install software-center or sudo apt install software-center in some versions of Ubuntu.), Ubuntu update center will install a version for your version of Ubuntu, then if need be you can upgrade wine. It should save you a lot of trouble.

Otherwise you can also use "Synaptic package manager"(Also in Ubuntu software center.). I heard about Synaptic here in a reply to a different question.) to do the install(Find wine using Synaptics search, right click mark for install, then click the apply button.) it can do all the dependency stuff for you. Synaptic also has a "fix broken packages" which has saved me lots of time and effort.

By the way you mite like "wincfg" helps setup wine, and "wine tricks" and "Qtforwine" these help setup applications in wine, all are in Ubuntu software center or can be found threw Synaptic.

Anyway I hope this helps. By the way I'm using an older version of Ubuntu 14.04 but I did "look up the info" to make sure it still works.

2
  • using synaptics is giving me the same results as when i use apt to install wine, it wants to remove main system packages so the i386 can be installed Feb 4 '18 at 15:25
  • The software center is your best bet, a it has a version setup for your version of Ubuntu. I am not sure what to tell you otherwise, there is a possibility system files need to be updated to use a specific version of wine. You can generate a package download script in Synaptic to see what it is downloading. I have never had a problem by just letting Synaptic do its thing, its always just worked. Otherwise I guess you will have to wait for a more knowledgeable person to reply.
    – DEH
    Feb 7 '18 at 2:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.