0

I would like to explore KDE 5 for my computer in Tuesday, but when I made a USB stick for Kubuntu, everything went fine and all the files copied without errors. I went to the Boot Menu to boot from USB, the boot menu showed up properly.

I selected Start, everything boots up fine, even the installation part. I pressed Try, but when it finally loaded, I saw the non-blinking hyphen and the mouse cursor appeared for a few seconds and then disappeared.

When I waited more, the hyphen disappeared, but it could not get past the black screen. I tried to restart several times but this same problem occurred. I tried to turn on/off Num Lock light but it does not turn off/on. Not even REISUB worked and I have to wait for hours for the splash to appear, or force-reset my computer.

I could run KDE 4, so I should be able to run KDE 5 without problems. I even installed Kubuntu to the hard disk, but the installed thing failed to go to the desktop, just like the "Try" situation.

I even tried with nomodeset, but I just got the 720x400 text output, mostly Systemd, and then I got the Output not supported by the monitor.

I even re-downloaded it, leaving it downloading for the night. I returned, and hashed the new ISO, and the hash appears to be the same.

When I made Kubuntu USB again, and booted from it, this time, it was showing the SQUASHFS errors, and then, the installation part started without any decorations. I pressed try, same problem.

I made yet another Kubuntu USB (this time, it was in another slot) and booted from it, same SQUASHFS errors, and the installation part started with decorations like before. I pressed try, and it took me to the TTY1 and I could log-in to Kubuntu to write commands, but not be able to start X11 server.

I regret formatting again, so I just hashed the filesystem.squashfs file on the USB with the one which is provided on the correctly-re-downloaded ISO. The checksums is different despite the re-dwnloaded ISO has the same checksum that the original checksum file provided. I then copied the non-corrupted filesystem.squashfs into the casper folder on the USB.

I booted again, this time, there is no SQUASHFS errors and the installation part started with decorations. I pressed try, and the same problem started (black screen, computer frozen, no indication of kernel panic)

Today, I woke up to the alternative laptop, and I let it boot Kubuntu. It booted successfully, pressed Try, and a black screen appeared for a few seconds and then the splash appeared, and then I got the desktop!

I tested Kubuntu in VirtualBox on the affected computer, but the desktop appeared without the breeze splash screen, although the performance is very slow, because I waited for a matter of the minutes for KDE 5 desktop to appear, and it actually appeared.

It is weird that the alternative laptop and VirtualBox on the affected computer can go to KDE 5 desktop but the affected computer which was booting from the USB failed to go to the desktop, resulting in a black screen which is impossible to do anything except shutdown or reset button.

By the way, I am trying out Kubuntu 17.10.1.

My system specifications:

  • AMD Athlon XP 1500+ (1 GHz)
  • 2 GB RAM
  • AMD Radeon 9200 Series (128MB)
  • WDC Hard disks (each of 40GB)
  • MSI MS-6712 (KT4AV version that is able to boot from USB without external bootloaders like Plop Boot Manager, even if it is below 2006)

Is it my USB ports? The front is always slower than the back.

Is there anyway to get out of the black screen without re-downloading, because the hash matched? Is it my computer, or is it just KDE 5 who failed to start? How can I solve this problem?

  • don't u think that you gave more description then required – Prateek Agrawal Feb 11 '18 at 17:50
0

It was my graphics card who cannot handle OpenGL 2.0 as KDE 5 needs at least OpenGL 2.0. When it freezes, KDE sends impossible demands to the graphics card as it could not create shader because it does not have OpenGL 2.0, and KDE does not give up to go to software renderer, so my graphics card is stuck and so my computer. It did not affect games.

I installed Xubuntu, then I installed KDE 5, then I forced QT to go to software renderer by going to /etc/security, putting an environment variable for QT to use software rendering.

Everything works like usual, but I saw a 100% transparent panel, could click on taskbar buttons, nothing else than them (could not click or hover on app icons on start menu), and clicking OK on error causes KDE to give up, crashing to the lightdm wallpaper, and I have to go to TTY to do kill -9 -1 to restart the DM.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.