2

Disclaimer
I am not a Linux expert. I use Ubuntu to educate myself about Linux and to run my Kodi media center, so when things go wrong, I like to try to fix them instead of simply re-installing or going back to a previous snapshot (which in this case isn't working either!).

Background
So I recently did a system update on my 16.04 and a lot of files were downloaded and installed (I'm assuming this update included the Intel Spectre/Meltdown bug fixes to the kernel). I also upgraded my VirtualBox host to 5.2.6 and installed the latest Guest Additions package. Everything seemed fine except I started to have sound issues (Sound Problem With VirtualBox -5.2.x branch). One of the suggestions on that thread was to revert to an earlier version of Virtualbox, which I did, but couldn't get any of my Ubuntu VMs to boot. It seems that due to the patches for the Intel CPU bug, to enable me to use an old version of VirtualBox, I would need to downgrade my kernel. As this is beyond my abilities, I decided to just re-install the latest 5.2.6 VirtualBox host instead.

Problem
This is where the fun and games start. My Ubuntu VM wouldn't boot! I was able to get to the GRUB boot selector and tried each of the 3 kernels listed, but in each case the boot process would stop at the same place.

GRUB boot window

Boot Window

I did some research and tried disabling a few things (3D acceleration, network adapters, sound card etc), but from what I can see in the boot window, its not even getting close to requiring those items so I cant see how they can be the issue. I tried reverting back through several snapshots of the VM, but all of them experienced the same issue, which now makes me believe there must be something corrupt with the VM container.

I've posted this problem here because I was hoping someone could educate me as to the correct course of action to evaluate and fix a non-booting Ubuntu system. I appreciate that VirtualBox is probably part of the issue here, but I have to choose one path of evaluation before another.

Things I've tried

  1. Tried all 3 kernels in recovery mode
  2. Tried disabling graphics, network and sound cards
  3. Booted into a Ubuntu 16.0.4 LiveCD to do a repair install, but wasnt given an option to "install but keep files" even though it detected that I had a current installation on the disk
  4. Tried a couple of different Linux VM's I've got (Kali, CentOS) and a Windows 10 VM which all worked fine but I've not yet patched any of them.

Concluding notes I created a brand new 16.0.4 VM, fully patched it and it ran fine, hence another reason why I think its a corrupted container. I am having problems getting the latest Virtualbox Guest Additions to enable 3D acceleration (even after following Oracle VM VirtualBox 5.1: 3D Acceleration for Ubuntu guests), but with acceleration disabled, at least it runs (but still have the sound issue!).

I don't want to give in. There appears to be further GRUB boot options that I've never used before (e.g. 'c' for a grub command line), so any help trying to educate me on resolving such a difficult issue would be appreciated.

1

I had the same issue. After fighting with VBox for 4 hours, finally I won. The change I had to do was enable back 3d acceleration and thing which I think made it workis the "Version" mentioned in "Settings->General->Basic". I set it to "Ubuntu (64-bit)" instead of the 32 bit version, and voila, it worked.

1
  • My Ubuntu VM was working fine. Then I upgraded to 5.2.20 and it was not working. I would get to the GRUB screen, select to boot Ubuntu and then only get a blinking cursor. No boot log scrolling away.Turns out the Version was set to Ubuntu 32 bit. Setting back to Ubuntu 64 bit fixed the issue. HTH someone else. – ds00424 Oct 23 '18 at 14:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.