I would like to implement a keyboard shortcut to restart gnome-shell whenever this one crashes (some bugs aren't currently fixed just yet). For this I would need a command line to restart the shell.

The Alt+F2 and restart command won't work when the shell is crashed because the prompt is implemented in the shell.

Hence, how to restart the gnome-shell from command line?

  • 1
    NOTE: Alt+F2 and restart will stop all the running programs. (I still don't know how to restart the GUI without stopping the programs.) Aug 17, 2018 at 6:38

10 Answers 10


GNOME Shell 3.30.1 on Ubuntu 18.10

The command to replace gnome-shell would be sending a SIGQUIT signal to it with:

killall -3 gnome-shell


killall -SIGQUIT gnome-shell

As of GNOME Shell 3.30.1 on Ubuntu 18.10, the solution below no longer works, and will kick the user to the login screen, losing all of their work.

Before GNOME Shell 3.30.1

The command to replace gnome-shell would be:

gnome-shell --replace &

The ampersand is added to return the shell prompt after running the command; pressing Ctrl+C or closing the terminal instead would make the desktop unusable, and require a full restart.

From the manual page of gnome-shell:

-r, --replace
       Replace the running window manager

Unsure which version you are using?

The command to check your GNOME Shell version is:

gnome-shell --version
  • 4
    Thanks I wasn't sure --replace = "restart". Jan 31, 2012 at 15:56
  • 7
    As of GNOME Shell 3.30.1 on Ubuntu 18.10, this solution no longer works, and will kick the user to the login screen, losing all their work. The correct solution is now commandline: "killall -3 gnome-shell", or ALT+f2 and r (if possible).
    – C.Rogers
    Nov 15, 2018 at 10:48
  • 2
    ALT+f2 (show command prompt) + gnome-shell --replace will work nicely in 18.04. All running programs won't be stopped.
    – lifeisfoo
    Jun 10, 2019 at 12:42
  • 2
    @Sparr - thanks for the warning. Fortunately, the killall -3 gnome-shell answer seems to work on Ubuntu 19.10.
    – bitinerant
    Nov 11, 2019 at 21:03
  • 2
    Ubuntu 20.04 Gnome version 3.36.8, doing killall -3 gnome-shell forced me to login again and closed all my apps.
    – wxz
    Nov 10, 2023 at 17:43

The easiest way is to Alt+F2 and type r then .

  • 11
    That is true, but exactly not the question. The question then is: what happens when you do this. So that you can do it yourself
    – sehe
    Jan 21, 2017 at 11:34
  • 9
    As of GNOME Shell 3.30.1 on Ubuntu 18.10, and commandline: "killall -3 gnome-shell" are the only solutions posted here that work. All others kick the user out to login screen, losing all their work.
    – C.Rogers
    Nov 15, 2018 at 10:49
  • 6
    Tried this on debian buster. Getting "Restart is not available on wayland" error.
    – livinston
    Aug 14, 2019 at 21:49
  • 3
    Amazing! That was so simple on Ubuntu 19.10 :) Thank you!
    – yanike
    Jan 23, 2020 at 1:40
  • 1
    This one works for me on Xorg display server. But on Wayland, for now, no way to make it work.
    – fsevenm
    Mar 21, 2020 at 8:09

Since GNOME Shell 3.30.1: You can also do a killall -3 gnome-shell.

  • 1
    Probably because this is a good solution where the other command doesn't work. I tried both, the choosen one is good but didn't solve my problem, while this did.
    – Mitro
    Nov 5, 2018 at 10:00
  • 4
    As of Ubuntu 18.10, GNOME Shell 3.30.1 - THIS IS THE CORRECT SOLUTION. All other solutions restart the session and kick the user out to the login screen, losing all their work.
    – C.Rogers
    Nov 15, 2018 at 10:44
  • 3
    SIGQUIT (3) doesn't kill the process
    – Jack Wasey
    Jan 1, 2019 at 11:22
  • 1
    This seemed to work for me. Whereas I was using gnome-shell --replace & before. It worked but, kept running in the terminal. The issue I was having was with Youtube videos in full screen somehow causing Dash-to-Dock and the panel to freeze closed. github.com/micheleg/dash-to-dock/issues/…
    – Natetronn
    Apr 18, 2019 at 23:48
  • Matter of style: a Unix sysadmin might prefer pkill -3 gnome-shell rather than killall, which means something different outside of the GNU OS.
    – Rich
    Aug 8, 2019 at 18:57

In the case where the whole GNOME Shell got frozen, there is a way to restart it from the terminal without restarting the whole X window:

  1. Press Ctrl+Alt+F2 to switch to a TTY terminal.

  2. Log in with your credentials (username and password) and then run:

    DISPLAY=:0 gnome-shell -r & 
  3. Log out by running:

  4. Press Alt+F1 to switch back to a graphical X windows session.


Before GNOME Shell 3.30.1 the command should just be gnome-shell --replace.

  • 5
    As of GNOME Shell 3.30.1 on Ubuntu 18.10, this solution no longer works, and will kick the user to the login screen, losing all their work. The correct solution is now commandline: "killall -3 gnome-shell", or ALT+f2 and r (if possible).
    – C.Rogers
    Nov 15, 2018 at 10:50
  • doesn't work for a remote session, so when gnome shell has frozen, this doesn't work.
    – Jack Wasey
    Jan 1, 2019 at 11:21

The Gnome 40 the equivalent of Alt+F2 restart is:

busctl --user call org.gnome.Shell /org/gnome/Shell org.gnome.Shell Eval s 'Meta.restart("Restarting…")'

Got this tip myself from https://www.linuxuprising.com/2020/07/how-to-restart-gnome-shell-from-command.html.

  • worked on Debian 11.0
    – rofrol
    Oct 5, 2021 at 19:46
  • I wanted to note that this took a few seconds (screen turned black) and then all my apps were closed on 21.10.
    – LiveWireBT
    Nov 26, 2021 at 3:28
  • This doesn't work for me anymore in GNOME Shell 42.5
    – curusarn
    Oct 26, 2022 at 19:03
  • For Gnome Shell 43 (on Xorg), the command is now: busctl --user call org.gnome.Shell /org/gnome/Shell org.gnome.Shell Eval s 'Meta.restart("Restarting…", global.context)'. However, executing GJS like this is unfortunately no longer supported by default. You have to run global.context.unsafe_mode = true in Looking Glass first, which makes this rather unhelpful for frequent restarts
    – ZimbiX
    Jan 18, 2023 at 8:24

Sending TERM signal to Gnome Shell 42.1 works for me on Ubuntu 22.04:

pkill -TERM gnome-shell

Note: TERM is the default signal for pkill.


I came up with this function to logout users (see at the bottom)

It assumes

  • you have sudo permissions
  • you have bash
  • the users have 1 running X session (although you should be able to issue the same logout command multiple times to get rid of remaining sessions)

You can give it multiple usernames:

logout john jane mike elisa

And you can give it additional options:

logout john --force

So, I have the following helper function:

function forcelogout() {
    logout "$@" --no-prompt --force


  • This is a blunt instruments and works by just copying the entire session environment. This could be more selective.
  • Sometimes logout seems to take a while
  • In rare occasions the session keeps being reported until someone visits the vt where the session ran, but nothing is there anymore)


function logout() {
    local USERNAME
    export USERNAMES=( ) 
    while [ -n "$1" ]; do case "$1" in
        -* ) break ;;
        *) USERNAMES+=( "$1" ); shift ;;
    esac; done

    for USERNAME in "${USERNAMES[@]}"; do
        local SESSION_PID=$(pgrep -fu "$USERNAME" gnome-session|head -1)
        if [ -n "$SESSION_PID" ]; then
                sudo -u "$USERNAME" cat "/proc/$SESSION_PID/environ" | xargs -0 -n 1 echo export
                echo "gnome-session-quit --logout $@"
            ) | sudo -u "$USERNAME" sh -;
  • logout USERNAME --force, gives me an output telling me a number is necessary.
    – Quidam
    Jun 4, 2020 at 5:11
  • 1
    @Quidam That indicates that the variable is not set to a value. You need to set it (which is what happens in the script)
    – sehe
    Jun 4, 2020 at 9:39

I defined an alias: alias gnomeshellrestart='echo "gnome-shell --replace -d" $(w| grep "$USER"| awk "{print \$3}"|grep ":"|head -1)| at now'

You may be able to start a terminal by right-clicking with the mouse on background and type there (alt-tab is dysfct then, too), if not, login to a tty with e.g. ctrl-alt-F2 and run from there.


In order to proper restart all related, I prefer restarts of whole stack (if tty1..4 works)

sudo killall -9 gdm
sudo killall -9 gdm3
sudo killall -9 lightdm

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .