2

I have a Dell XPS 13 9360, which I'm trying to get VirtualBox running on. I've followed guides to generate a MOK signing key, such as Could not load 'vboxdrv' after upgrade to Ubuntu 16.04 (and I want to keep secure boot) , and then run /usr/src/linux-headers-$(uname -r)/scripts/sign-key with the stated parameters on vboxdrv.ko. sign-key exits with code 0, indicating success, with no messages. However, when I examine the 'signed' file with modinfo, I only see:

modinfo ./vboxdrv.ko 
filename:       ./vboxdrv.ko
version:        5.0.40_Ubuntu r115130 (0x00240000)
license:        GPL
description:    Oracle VM VirtualBox Support Driver
author:         Oracle Corporation
srcversion:     6D8B4900A693FC50489A130
depends:        
name:           vboxdrv
vermagic:       4.13.0-32-generic SMP mod_unload 
parm:           force_async_tsc:force the asynchronous TSC mode (int)

I'm supposed to see signer, sig_key and sig_hashalgo, but I'm not seeing any of this. I've tried running on another machine with the same kernel, and the same result. No errors, but no signature.

The exact command I'm running (as root):
/usr/src/linux-headers-4.13.0-32-generic/scripts/sign-file sha256 ./MOK.key ./MOK.der ./vboxdrv.ko

The file size of vboxdrv.ko seems to increase by a couple of KB each time I run sign-key, so it's doing something, but I cannot tell what. I've also used the optional final argument to sign-key to output into a new file (rather than in-place) and the new file also does not have a recognisable signature.

Edit: I should have mentioned, after loading the key into the UEFI key manager and rebooting, I still receive Required key not available when trying to load the 'signed' kernel module.

Any ideas how to debug this?

  • What happens when you reboot or try to load the kernel module ? What makes you think you have a problem ? – Panther Feb 1 '18 at 17:14
  • @Panther sorry, I should have been clearer. When trying to load the post-signed file, I still receive Required key not available. I have loaded the MOK.der key into the UEFI key manager. – Gargravarr Feb 1 '18 at 20:39
  • sudo mokutil --import MOK.der,like askubuntu.com/questions/760671/… – L-ios Apr 23 '18 at 1:43

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.