I am stuck with this one, have tried apt-get install -f, dpkg --configure -a and they both tell me about the same.

I have no held packages (dpkg -l|grep -i '^h' is empty). Where do I start to look?

# apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 compiz-plugins : Depends: compiz-core (= 1: but 1: is installed
                  Depends: compiz-plugins-default (= 1: but 1: is installed
 libcompizconfig0 : Depends: compiz-core (= 1: but 1: is installed
 libgail-3-0 : Depends: libgtk-3-0 (= 3.22.25-0ubuntu0.1) but 3.18.9-1ubuntu3.3 is installed
 libmetacity1 : Depends: metacity-common (= 1:3.26.0-1) but 1:3.18.7-0ubuntu0.3 is installed
                Depends: libgtk-3-0 (>= 3.20.0) but 3.18.9-1ubuntu3.3 is installed
 metacity : Depends: metacity-common (= 1:3.26.0-1) but 1:3.18.7-0ubuntu0.3 is installed
            Depends: libgtk-3-0 (>= 3.21.5) but 3.18.9-1ubuntu3.3 is installed
 unity : Depends: libunity-core-6.0-9 (= 7.4.0+16.04.20160906-0ubuntu1) but 7.5.0+17.10.20171010-0ubuntu1 is installed
E: Unmet dependencies. Try using -f.

EDIT: As one answer comments, there are some mixed versions. This is because I tried to do a dist-upgrade to get rid of the error earlier. Apparently it has changed the error, but I believed it to be the same error, and didn't find the dist-upgrade relevant. My bad. I'll look into remove those pkgs then.

EDIT2: I don't think this is an exact duplicate of the two mentioned, at least not on at level I can comprehend.

QUESTION ANSWERED: I think the answers froms user535733 and karel are the ones that helped me. I'm sorry I do no seem to be able to accept the answer officially - could that be because the question is marked as a duplicate? I will try to accept again later.

Anyway: I pegged my installation at 16.04 (apt-get install -t xenial) and went around disabling the 17.10 packages. But then I got lost, gave up and made a clean 17.10 installation. Thanks for your time :-)

marked as duplicate by Eric Carvalho, karel, Zanna, Volker Siegel, Elder Geek Feb 2 '18 at 14:52

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Have you run apt-get update recently? What Ubuntu version do you use? – Melebius Feb 1 '18 at 14:00
  • The tag says 16.04, but the unmet dependencies results in the question say Depends: ... 17.10. – karel Feb 1 '18 at 14:12
  • 2
    You seem to be trying to mix packages from two different releases of Ubuntu. That's unwise for several reasons...including that it breaks your system in precisely this way. Pick which release you want, and stick to it. Uninstall all packages from the other release, and remove those sources. – user535733 Feb 1 '18 at 14:17