0

Ubuntu 17.10 (X.Org), GNOME 3.26.2.

I suddenly began having this problem when I try to run gnome-terminal, I can't figure out what caused this:

main19@system19:~$ gnome-terminal

Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached

This causes gnome-terminal not to start. I have tried looking online, everyone says it is a locale problem, here is my locale output:

main19@system19:~$ locale

LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Output of localectl:

System Locale: LANG=en_US.UTF-8
VC Keymap: us
X11 Layout: us
X11 Model: pc105+inet
X11 Options: terminate:ctrl_alt_bksp

I have run out of ideas, if anyone can provide help with this that would be great.

  • Forgive the stupid question, but, if you run gnome-terminal command from a terminal... which terminal is that ? – Robert Riedl Feb 1 '18 at 9:32
  • Robert Riedl, I had to install another terminal program, I installed Sakura. – dln949 Feb 1 '18 at 17:04
  • are you running this gnome-terminal in a su or sudo shell ? – Robert Riedl Feb 1 '18 at 17:15
  • things you can check: is localectl looking good ? or maybe its a dbus issue ? – Robert Riedl Feb 1 '18 at 17:21
  • I am not attempting to use su or sudo or any variations of that. I have edited the original message to show the output of localectl. – dln949 Feb 2 '18 at 0:59
1

I ended up refreshing my HOME directory, cleaning out all kinds of old "junk" from it, paying special attention to cleaning out the .config directory. I also created a new user so I could get a fresh copy of the .bashrc and .profile files. This appears to have solved this (and another) problem.

0

This might be irrelevant for most, but uninstalling chrome-remote-desktop and then restarting the computer worked for me. The package is simple to remove:

sudo apt remove chrome-remote-desktop

This seems to be a known bug.

Simply removing the extension from Chrome was not enough, possibly because I have multiple Chrome profiles with that extension. I had to uninstall it using apt.

The bug report also mentions that simply disabling remote connections in the extension is enough, you don't have to remove the extension entirely.

-1

Quickest fix: open a prompt using Alt-F2 and run the following line:

dconf reset -f /org/gnome/terminal/legacy/profiles:/

This cleans out all the gnome-terminal profiles. The problem might be caused by old profiles within gnome-terminal, that have unfinished command lines or invalid preferences.

(And try rebooting your system...)

Update: Your problem persists over reboots, yet only in gnome-terminal. I think that means the problem should be somewhere in your configuration files for gnome-terminal. To find out if it's just in your profile: try logging in as root using sudo -i. Try gsettings list-recursively | grep -i term for clues. Are there any clues in you .profile of .bashrc?

  • Thanks, but..... nope. I did as you instructed. No discernible change, still the exact same problem. – dln949 Feb 2 '18 at 15:27
  • pm-b, thanks for the suggestions, but.... I'm sorry, I looked at the output of what you suggested, I simply am not able to decipher what it is telling me, so I don't know what is good or bad. Also - I did not understand your last question, what is meant by the ".profile of .bashrc"? How would I find the .profile of .bashrc? – dln949 Feb 3 '18 at 2:37
  • The terminal is a "remote" through which you send commands to your computer. Whenever you start a terminal, it starts a shell (for example BASH). On startup, the shell sources a couple of files in your home folder (e.g. .profile and .bashrc), in which the general options and environment are set. Variables like LC-*, holding locale settings, are usually set in one of these files and sources each time the shell starts. – pm-b Feb 3 '18 at 6:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.