0

I just switched from windows 10 to Ubuntu 16.04 and now my Laptop Dell Inspiron does not communicate with the Brother Color Laser Jet printer even if I use the printers USB cable. The laptop sees any thumb drive plugged into any of the three ports. But never the printer.

I contacted Brother and they sent me drivers for Ubuntu for the CW3180CDW printer and the software downloaded and there is an icon under printers and it is the selected printer. If I try to manually install the IP address into printer info and hit enter I get an instant CUPS error. The printer works normally with four other computers on my LAN. What is strange is that every so often I can hit print a test page and it will on the wireless network. It will not print a test page every time and it will not print any photos or data.

Ubuntu says it is printing and the working bar crosses the page but nothing happens at the printer. Ubuntu never shows any jobs pending or working. If I use another computer and look for the printer it sees it idle and will send to it instantly. If I look for the printer in Ubuntu, the icon of the printer is there but it always says "off-line". I'm new to this OS and even with help from another who is very good with this OS he too cannot get the printer to work. Thanks for your help.

cups error 2/12/2018

enter image description here

enter image description here

  • Have you tried installing through CUPS to see if you can get the printer installed? See: askubuntu.com/a/866860/231142 but ignore the parts of PlayOnLinux. – Terrance Feb 10 '18 at 22:39
0

so Brother provide an installer tool to install the software you need; if you go here:

Brother - Driver Install Tool

and click to download and SAVE what will be linux-brprinter-installer-2.2.0-1.gz

you need to open a terminal; so press three keys: control and alt and t and a black screen opens ......

next you need to copy the commands I list below; copy each command line by line; paste each line into the terminal; hit the ENTER key after each paste; ... then move on to the next command ..

....... so three separate pastes; ENTER key after each paste ..

and how to paste into a terminal; if you right-click at the text prompt in the terminal; .. that is the flashing light in the terminal ..then when you right-click; a menu appears; and PASTE should be there?

so when you click to download linux-brprinter-installer-2.2.0-1.gz, it should end up in your Downloads folder .. so ...

cd Downloads

gunzip linux-brprinter-installer-2.2.0-1.gz

sudo bash linux-brprinter-installer-2.2.0-1 HL-3180CDW

and that last command runs the installer script; so watch the screen as it may stop at some point and ask you some questions;

it will ask you for your sudo password; so have that ready;

and later on in the install it will ask you if you want to specify Device URI; say Yes; you are networked so look for the ip address line

let's see how the above all goes


so you have HL-3180CDW and Brother say you need hl3180cdwlpr-1.1.3-0.i386.deb and hl3180cdwcupswrapper-1.1.4-0.i386.deb and your screenshot shows you have both installed; so all should be good ... I would suggest you go to your PRINTERS folder; delete any existing entries for the 3180; then click on the ADD button at top-left; let it look and see what it finds; it should find the 3180; and see if Ubuntu can help you move forward;

if you could tell us what lpinfo -v gives from a terminal please

and check all the cups stuff is installed with dpkg -l cups*

  • I downloaded the loading tool and sent it from the desktop to downloads. I added the three lines of code and my password and the warning that I was going to download the software in red was displayed. I typed a "Y" and nothing happened. I typed the word yes and the terminal filled my screen with lower case Y's The last Y on the screen flickers back and forth and will not stop. If I type exit the warning that a terminal function is still running and I should wait. –  Rapidrob Feb 1 '18 at 23:37
  • I had to reboot the laptop. I tried the commands again and a bunch of data was loaded. Towards the bottom of the screen an error showed up just before "print a test page?" No idea what it meant. I hit yes for print test page and it looked like it tried. Nothing was printed. –  Rapidrob Feb 2 '18 at 0:26
  • I have a screen shot but do not know how to attach it here. –  Rapidrob Feb 2 '18 at 0:28
  • to add a screen shot, I think if you go back to your initial statement; you can edit that; and add a screenshot; let's see if you can find it; otherwise, I will hunt around and try to find a how-to for you – pdc Feb 2 '18 at 2:07
  • Thank you so much for your help. I know enough about Ubuntu to be dangerous at this point. I could be doing something wrong and not know it. –  Rapidrob Feb 2 '18 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.