I'm following a Cousera course on Machine learning. We have to use some specific tools such as Graphlab create. Yet, after installing Anaconda with

bash /Download/Anaconda2-4.0.0-Linux-x86_64.sh

I had to create a new conda environment with Python 2.7.x (I don't now why they didn't moved to python 3 but it seems that it is the way the teachers do its thing on)

conda create -n gl-env python=2.7 anaconda=4.0.

And it ansswered me conda: command not found

I read the related question posted by vincent and tried the best answer by George Udosen with

sudo mv /root/anaconda3 /home/$mike

But still, I received mv: cannot stat '/root/anaconda3': No such file or directory

3 Answers 3


I found an answer in madcurie's answer

for anaconda 2 :

export PATH=~/anaconda2/bin:$PATH

for anaconda 3 :

export PATH=~/anaconda3/bin:$PATH

for anaconda 4 :

Use the Anaconda Prompt

and then

conda --version  

to confirm that it worked.

  • this does not work
    – Garglesoap
    Oct 6, 2020 at 0:25

I was installing Anaconda3-2019.07-Linux-x86_64 (.sh) and was facing the problem of conda not being found as a command.

The problem was in the .bashrc entry that the installer was setting. I Needed to add

export PATH=~/anaconda3/bin:$PATH

in the if entry of

if [ -f "$anaconda3_path/etc/profile.d/conda.sh" ]; then...

I had the same problem !

You should know first where you have installed anaconda3. If it is installed in /root/anaconda3 so you should first change the user to the root by

sudo su

Then you can activate one of conda environments:

conda activate [env]

If anaconda3 is installed in user's directory such as /home/[user-name]/anaconda3, you should not have trouble unless the path of conda command is not in the PATH variables.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .