0

I'm running Windows 10 and Xubuntu. I had a windows update few days ago. After that, the GRUB menu disappeared. The solution I used was loading Windows and from command prompt using

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi 

as suggested in Windows 10 upgrade kills grub and boot-repair doesn't help.

This partially solved the problem, now I get to the GRUB and I can load both Windows and Xubuntu BUT after lots of errors before I get to GRUB.

First, when the laptop turns on, I have a few statements:

Failed to open \EFI\Boot\grubx64.efi - Not Found
Failed to load image \EFI\Boot\grubx64.efi: Not Found
start_image() returned Not Found
Failed to open \EFI\BOOT\grubx64.efi - Not Found
Failed to load image \EFI\BOOT\grubx64.efi : Not Found
start_image() returned Not Found 

Then it goes to next screen and it shows me this message:

Default Boot Device Missing or Boot Failed.
Insert Recovery Media and Hit any key
Then Select 'Boot Manager' to choose a new Boot Device or to Boot Recovery  
Media

After I click "Ok" (which is the only option here to click), it loads Boot Manager screen:

Boot Option Menu

1. Linpus lite(TOSHIBA MQ01ABF050)

After I click enter because I only have one option here, it repeats error messages I already had on start:

Failed to open \EFI\Boot\grubx64.efi - Not Found
Failed to load image \EFI\Boot\grubx64.efi: Not Found
start_image() returned Not Found
Failed to open \EFI\BOOT\grubx64.efi - Not Found
Failed to load image \EFI\BOOT\grubx64.efi : Not Found
start_image() returned Not Found 

After this, it just loads GNU GRUB with options to choose from Windows and Ubuntu(Xubuntu) etc.

From this point, everything works as usual. I do not get any errors or experience any kind of problems while working on Windows or Xubuntu.

My boot order is set to USB first and Hard Drive second. I tried to change order after I experienced this problem but now I cannot even access my BIOS. This is very unusual behavior, I always could access my BIOS. Now when I press F2 on startup, it doesn't load into BIOS, it asks me for a password. I never set a password for BIOS and I am the first owner of this laptop, nobody else ever used it either. So no mistake there.

I tried just clicking enter and leaving password field blank as I read somewhere but it didn't work.

As I'm a complete newbie to these kind of things, I tried to repair GRUB from Xubuntu but this didn't improve situation (or made it worse).

I'm looking for a solution that includes repairing bcdedit thingy.

Reseting laptop is not a solution right now, I am leaving that as my last option because I have a lot of files to transfer and a lot of projects currently in progress.

Thank you all in advance. And yes, I realize I shouldn't have messed with bcdedit if I'm clueless about it.

UPDATE

As oldfred suggested, I copied all files from /EFI/ubuntu to /EFI/BOOT folder and problem with errors was solved. Or I don't see it anymore, can't tell.

Problem with system asking for BIOS password is still there. I repeat: I never set password; It worked before whole grub mess just fine (I was able to access BIOS); Password isn't blank.

  • 1
    There is not normally a /EFI/Boot/grubx64.efi. That file is in /EFI/ubuntu. But if using the fallback boot of /EFI/Boot/bootx64.efi which may really be shimx64.efi, the that file may need grubx64.efi. So copy all the files from /EFI/ubuntu into /EFI/Boot. I would back up everything in your ESP - efi system partition first, just in case. Use live installer to mount /EFI/ubuntu & /EFI/Boot folders. – oldfred Jan 31 '18 at 19:49
  • Thanks for reply mate but I'm on much lower level. I followed instructions from the link I provided and people said that it works, so I guess the path exists. :\ – trbste Jan 31 '18 at 19:59
1

I had the same problem - dual boot Windows 10/Lubuntu computer which would no longer show the GRUB dual boot menu after the Spring 2018 Windows 10 upgrade.

On my Dell machine the F12 key brings up a Boot Order menu. On other devices, this kind of menu or the BIOS/UEFI firmware may be accessed by another F key or by esc or del. This saved me a lot of potential work: I kept pressing F12 during startup, and the computer went into its own boot menu with separate entries for Windows and Lubuntu.

I selected Lubuntu, and then I opened a Terminal and entered

sudo grub-install /dev/sda

(both operating systems are on /dev/sda on my computer). GRUB dual boot menu was reinstalled and dual boot is working fine again. Total time about 3 minutes. Hope your system has the same options available.

| improve this answer | |
  • I don't think that can be the solution here - OP seems to have got past that stage and wound up with a worse problem! – Zanna May 16 '18 at 6:22
  • Upped this answer anyway because it helped my case. Last W10 update did "something" to grub and W10 couldn't boot (Ubuntu still ok though). After grub-install, everything works again. – LittleBigDev Sep 15 '19 at 22:32
1

Ok I solved the problem (I believe), so I will share how I did it to help others with same problem.

As oldfred suggested, I copied all files from /EFI/ubuntu to the /EFI/BOOT folder and the problem with errors was solved. Or I don't see it anymore, can't tell.

Problem with system asking for BIOS password was still there. It didn't happen before this mess. Rest of my solution has nothing to do with Ubuntu.

If you miss your BIOS password 3 times in a row, system will lock your computer and give you a System Disabled number. You will need this number.

Open BIOS master password site. Enter the system disabled number you wrote down and check the list of master passwords. Find your manufacturer and enter the password for it.

| improve this answer | |
0

On Dell XPS I found that the following worked:

o Turn off fast boot in Windows, this allows the F2 key to bring up BIOS

o In BIOS disable the Windows Boot Manager.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.