0

Whenever I install apps from the software center it doesn't install but a shortcut of the app I want to install appears on the bar but not installed and pending.

So I tried installing stuff through terminal .

Example I wanted to install Gdebi so I typed

sudo apt install gdebi 

And I got:

sudo: unable to resolve host vision
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 cpp-5 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed
 g++-5 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed
 gcc-5 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed
 gdebi : Depends: gdebi-core (= 0.9.5.7ubuntu1) but it is not going to be installed
         Depends: gksu but it is not going to be installed
         Depends: gnome-icon-theme but it is not going to be installed
 libasan2 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed
 libatomic1 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed
 libcc1-0 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed
 libcilkrts5 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed
 libgcc-5-dev : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed
 libgomp1 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed
 libitm1 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed
 liblsan0 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed
 libmpx0 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed
 libquadmath0 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed
 libstdc++-5-dev : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed
 libtsan0 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed
 libubsan0 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

This happens everytime i install something even for vlc i got the same .Please help.

After resolving host when i tried to install vlc i got this

[sudo] password for nishanthr: Reading package lists... Done Building dependency tree
Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: browser-plugin-vlc : Depends: libvlc5 (>= 2.0.0) but it is not going to be installed cpp-5 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed g++-5 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed gcc-5 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed libasan2 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed libatomic1 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed libcc1-0 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed libcilkrts5 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed libgcc-5-dev : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed libgomp1 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed libitm1 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed liblsan0 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed libmpx0 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed libquadmath0 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed libstdc++-5-dev : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed libtsan0 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed libubsan0 : Depends: gcc-5-base (= 5.4.0-6ubuntu1~16.04.5) but 5.4.0-6ubuntu1~16.04.6 is to be installed vlc : Depends: vlc-nox (= 2.2.2-5ubuntu0.16.04.4) but it is not going to be installed Depends: libgles2-mesa (>= 7.8.1) but it is not going to be installed or libgles2 Depends: libqt5x11extras5 (>= 5.1.0) but it is not going to be installed Depends: libsdl-image1.2 (>= 1.2.10) but it is not going to be installed Depends: libsdl1.2debian (>= 1.2.11) but it is not going to be installed Depends: libva-drm1 (>= 1.1.0) but it is not going to be installed Depends: libva-x11-1 (>= 1.0.3) but it is not going to be installed Depends: libvlccore8 (>= 2.2.0) but it is not going to be installed Depends: libxcb-composite0 but it is not going to be installed Depends: libxcb-xv0 (>= 1.2) but it is not going to be installed Recommends: vlc-plugin-notify (= 2.2.2-5ubuntu0.16.04.4) but it is not going to be installed Recommends: vlc-plugin-samba (= 2.2.2-5ubuntu0.16.04.4) but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

  • 1
  • You seem to have unwisely installed software that is incompatible with your release of Ubuntu. This typically occurs when you install wrong-version software from some old PPA or other Non-Ubuntu source. Uninstall the non-Ubuntu software and then disable that source. – user535733 Jan 31 '18 at 15:58
  • How do I Uninstall the non-Ubuntu software and then disable that source ? – Nishanth R Feb 15 '18 at 12:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.