0

I have a package (say kaupackage) installed on my ubuntu machine. Now I want to replace it with higher version.

I run command

dpkg -i -R -B -a --force-confold /tmp/kaupackage.deb

The dpkg log shows

2018-01-31 06:37:22 upgrade kaupackage:amd64 2.2.0.0.0.7707465 2.2.0.0.0.7710866
2018-01-31 06:37:22 status half-configured kaupackage:amd64 2.2.0.0.0.7707465

and

dpkg -l

shows

iFR kaupackage  2.2.0.0.0.7707465  amd64  pkgdescription

I am not looking for workaround or solution to recover from this state. This command was working before and suddenly stopped working. So I need to know why.

How can I find out root cause ? Where can I find more logs ? How can I enable more logging ?

0

I don't think dpkg have a verbose option for installing packages... Although, I know there is a dpkg log in /var/log/dpkg.log.

I'd rather recommend to uninstall and install new version and or install package from a repository using apt-get kaupackage...

Do you see maybe something in syslog or in dpkg.log?

Regards,

  • In dpkg.log I see message saying package is half configured – Kaushik Lele Feb 1 '18 at 5:43
  • Have you tried installing the package in other host? Did it help you? could you give me a vote? – Alvaro Niño Feb 1 '18 at 8:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.