2

I would like to switch back to Xorg. Unfortunately, I do not see the button to switch the session as mentioned here: How do you switch from Wayland back to Xorg in Ubuntu 17.10?

login screen without desktop environment switcher gear icon (fresh install - ubuntu 17.10.1)

  • Just to clarify, it's not a button, but rather a drop-list on the Gnome login screen. You don't see anything there, and you're running 17.10? – richbl Jan 30 '18 at 23:31
  • No, there is just the login button, but not the little gear next to it. sorry, dont know how to make a screenshot. – kerner1000 Jan 31 '18 at 9:23
  • Try taking a picture of the login screen and adding it to your question. It's peculiar that you don't have the option (via drop-list) for choosing a session type in a default installation of 17.10. BTW, you do need to choose a user before you see the session options. – richbl Jan 31 '18 at 22:18
0

I have the same "issue". Turns out that my system is not compatible for wayland, so xorg is used by default - therefore the wayland based desktop didn't even get installed which leads to not even having the option to switch.

I checked my running processes - I run on xorg.

see this question

  • So there's no solution? I'm trying to use the Gnome shell but don't see a gear icon either, and it appears that my system is also not compatible according to this answer. – Mitch Apr 18 '18 at 6:23
  • Ah, never mind. I had to install gnome-shell, whereas omgubuntu.co.uk/2017/10/… just said I had to install gnome-session. – Mitch Apr 18 '18 at 6:33

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.