4

I have Dropbox installed on my Ubuntu machine, which is running Ubuntu 16.04, and it has worked fine until a few days ago, when I ran some upgrades through sudo apt-get upgrade, rebooted, and now Dropbox no longer starts.

If I run dropbox start, I get the following:

Starting Dropbox...dropbox: locating interpreter
dropbox: logging to /tmp/dropbox-antifreeze-gPhIu8
dropbox: initializing
dropbox: running python 2.7.11
dropbox: setting program path '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/dropbox'
dropbox: setting home path '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114'
dropbox: setting python path '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114:/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/python-packages-27.zip'
dropbox: python initialized
dropbox: running dropbox
dropbox: setting args
dropbox: applying overrides
dropbox: running main script
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/cryptography.hazmat.bindings._constant_time.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/cryptography.hazmat.bindings._openssl.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/cryptography.hazmat.bindings._padding.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/psutil._psutil_linux.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/psutil._psutil_posix.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/linuxffi.pthread._linuxffi_pthread.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/tornado.speedups.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/cpuid.compiled._cpuid.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/linuxffi.resolv.compiled._linuxffi_resolv.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/posixffi.libc._posixffi_libc.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/librsyncffi.compiled._librsyncffi.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/linuxffi.sys.compiled._linuxffi_sys.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/PyQt5.QtWebKit.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/PyQt5.QtCore.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/PyQt5.QtNetwork.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/PyQt5.QtGui.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/PyQt5.QtWebKitWidgets.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/PyQt5.QtWidgets.so'
dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/PyQt5.QtPrintSupport.so'
Dropbox isn't running!
Done!

Furthermore, if I launch the Dropbox app, the icon appears in the dock, blinks a few times, and then disappears, with no apparent effect. If I remember right, when I first installed Dropbox, the icon would blink, and a Dropbox login page would load via Google Chrome. But that is not happening now. I can open Chrome and log in to Dropbox via the web, no problem.

Following advice below, I tried installing nautilus-dropbox with aptitude, and I get the following output:

sudo aptitude install nautilus-dropbox
The following NEW packages will be installed:
  nautilus-dropbox 
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 2,720 B of archives. After unpacking 45.1 kB will be used.
The following packages have unmet dependencies:
 dropbox : Breaks: nautilus-dropbox but 2015.10.28 is to be installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     nautilus-dropbox [Not Installed]    

Accept this solution? [Y/n/q/?] Y
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

This seems to indicate that I have some missing or broken dependency, but I'm unclear on how to proceed.

Any suggestions?

  • is the daemon dropboxd running ? You could always try a re-install, maybe using the offline installer . – Robert Riedl Feb 2 '18 at 15:37
  • When looking through top, I don't see anything dropbox-related. I just downloaded the offline installer, but I'm not sure how to install it? It's a tar.gz archive. – Pascal Feb 2 '18 at 16:14
  • there should probably be a service in systemctl. Try sudo systemctl | grep service and see if there is anything dropbox related. Regarding the installer, try to extract it (richtclick) end see if there is an execute able install-script – Robert Riedl Feb 2 '18 at 16:18
  • Let's see... I don't find anything dropbox-related in systemctl. As for the installer, it extracts the directory .dropboxdist-dist but I'm not seeing an installer script. – Pascal Feb 2 '18 at 16:57
  • I stopped and started my dropbox for you, and I compared my output. It's exactly the same as yours, except just one last load: dropbox: load fq extension '/home/jean/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/PyQt5.QtDBus.so', and then Done! Can you look in this folder (with your username of course) if there is such a file? Does your dropbox say something in the log file mentioned in the first lines? – muclux Feb 2 '18 at 19:09
4

There appears to be some evidence that you manually installed dropbox possibly from here. Any attempt to install dropbox integrating packages via apt will be expecting approved versions from the repository. This I believe is the root cause of your problem. The solution is in the README file within the download archive. (Emphasis mine)

Thanks for downloading Dropbox! This is version 42.4.114 of the raw binary distribution of our syncing daemon. Normal users should not install this package manually and instead should use our main Linux package located at http://www.dropbox.com/downloading?os=lnx

To remove the version that you manually installed simply reverse the instructions on line 6 of the README. In effect remove the directory (.dropbox-dist) from your home directory (~, $HOME).

Then if you want to install the dropbox recommended deb. Download the deb that matches your Ubuntu architecture from here. and install it with your favorite package manager or to install the Ubuntu recommended version as suggested by this answer you will first need to correct your situation with held broken packages, ensure that you've enabled the multiverse repository and then issue the commands:

sudo apt update
sudo apt install nautilus-dropbox

Note that dropbox as notified upon installation you need to close and restart nautilus prior to launching dropbox and both nautilus and dropbox like all GUI applications are intended to be launched from the menu, not the command line.

  • Thanks for these suggestions! I decided to try to start over, so I deleted two directories in my home directory: .dropbox-dist as well as .dropbox. I also uninstalled dropbox and nautilus-dropbox with sudo apt remove. I then went to the dropbox website dropbox.com/install-linux, downloaded the installer, the installer downloaded the daemon. Now I'm back where I started: If I launch the dropbox app, it appears in the dock, blinks and eventually disappears with no apparent effect. – Pascal Feb 5 '18 at 23:42
  • And what happens if you install the version form the repositories? – Elder Geek Feb 6 '18 at 13:50
  • I installed dropbox only via apt, and restarted nautilus. It displayed the message Initializing nautilus-dropbox 2015.10.28, then the installer popped, prompting me to install the daemon. That runs through. When I type dropbox start, it runs through the same output as I've got posted in the original post, but it now hangs with the last shown line dropbox: load fq extension '/home/pascaltitle/.dropbox-dist/dropbox-lnx.x86_64-42.4.114/PyQt5.QtPrintSupport.so', and eventually tells me the daemon needs to be installed. If I then do dropbox start -i, I get identical output as originally. – Pascal Feb 6 '18 at 17:55
4
+25

It looks like integration between nautilus and Dropbox has been broken. You need install dropbox using repository as nautilus-dropbox is not available in repository.

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com FC918B335044912E
sudo sh -c 'echo "deb http://linux.dropbox.com/ubuntu/ xenial main" >> /etc/apt/sources.list.d/dropbox.list' 
sudo apt-get update 
sudo apt-get install dropbox 

Install dropbox daemon with following command and start it

sudo dropbox start -i 
  • 1
    This fails for me: Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: nautilus-dropbox : Depends: dropbox but it is not going to be installed E: Unable to correct problems, you have held broken packages. – Pascal Feb 4 '18 at 18:08
  • 1
    @Pascal askubuntu.com/questions/223237/… – Elder Geek Feb 4 '18 at 18:13
  • I posted some details in the main posting to follow up on this. – Pascal Feb 4 '18 at 18:36
  • edited answer. Above steps will resolve issue. – Ketan Patel Feb 10 '18 at 7:29
1

Sometimes I got similar trubbles with Dropbox. I solved them by removing its distro:

rm -r /home/pascaltitle/.dropbox-dist

On next start it downloads itself again and works nice.

0

I was finally able to resolve this problem, but because of how it happened, I'm not entirely sure what single step fixed my original problem.

After trying all of the checks and solutions proposed here, I followed the instructions for an advanced reinstall at https://www.dropbox.com/help/desktop-web/advanced-reinstall. This did not seem to solve the problem. But I then discovered that I had unlinked this computer from dropbox through the website a week ago. I had done it at the time because this computer was showing up twice in my list of devices, and I thought this might be creating a problem, so I removed it.

Once I logged in to dropbox through my web browser and reestablished this computer as an authorized device for Dropbox, the Dropbox box app automatically started up, and now everything works.

This whole time, I was fully expecting the Dropbox app to launch a login page in the first place, which is why it took me so long to discover this oversight.

Thanks to all for the suggestions!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.