6

Because of a hardware failure my motherboard has just been replaced. After the replacement, my system (Ubuntu 17.10) doesn't boot:

ALERT! UUID=dd84f4b3-d5bf-42e4-9b5e-ec685a461fad does not exist. Dropping to a shell.

I've used a Live USB Ubuntu to debug this problem. Here are some results:

/etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/nvme0n1p3 during installation
UUID=dd84f4b3-d5bf-42e4-9b5e-ec685a461fad /               ext4    errors=remount-ro 0       1

# /boot/efi was on /dev/nvme0n1p1 during installation
UUID=B38D-559B  /boot/efi       vfat    umask=0077      0       1
# swap was on /dev/nvme0n1p4 during installation
UUID=f4134c38-10b9-478f-b550-54650a9f5140 none            swap    sw              0       0

blkid

/dev/nvme0n1p1: SEC_TYPE="msdos" UUID="B38D-559B" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="98be6c97-c354-49a6-a432-9201d56a421b"
/dev/nvme0n1p2: LABEL="OS" UUID="B39E-7035" TYPE="vfat" PARTLABEL="fat32" PARTUUID="d3006358-8d82-4e0b-99f8-87a5261cf7e8"
/dev/nvme0n1p3: LABEL="UBUNTU" UUID="dd84f4b3-d5bf-42e4-9b5e-ec685a461fad" TYPE="ext4" PARTUUID="24e5b96d-f20c-43dd-9e48-672760b0e6f7"
/dev/sda1: LABEL="UBUNTU 17_1" UUID="88D4-322D" TYPE="vfat" PARTUUID="3d0a270b-01"

fdisk -l

Disk /dev/loop0: 1.3 GiB, 1427259392 bytes, 2787616 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/nvme0n1: 477 GiB, 512110190592 bytes, 1000215216 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 43E35EBE-2A73-404A-9D4A-851815F33F9A

Device             Start        End   Sectors   Size Type
/dev/nvme0n1p1        34     488281    488248 238.4M EFI System
/dev/nvme0n1p2    488282    5934980   5446699   2.6G Microsoft basic data
/dev/nvme0n1p3   5935104  933576703 927641600 442.3G Linux filesystem
/dev/nvme0n1p4 933576704 1000214527  66637824  31.8G Linux swap


Disk /dev/sda: 28.7 GiB, 30752636928 bytes, 60063744 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x3d0a270b

Device     Boot Start      End  Sectors  Size Id Type
/dev/sda1  *     2048 60063743 60061696 28.7G  c W95 FAT32 (LBA)

It looks like the UUID's in fstab are correct, but I still get that error message.

How can I repair my Ubuntu installation?

I've tried the given solution in ALERT! /dev/disk/by-uuid/xxxxxxxxx does not exist. Dropping to a shell, but unfortunately that didn't help (I mounted /dev/nvme0n1p3). Still the same problem.

Update: When I select UEFI boot mode in system setup, I still get this problem. But when I select legacy boot I got 'no boot device found'. But here comes the tricky part: when I select legacy mode and use F12 to select UEFI/Ubuntu, it starts without a problem.

  • 3
    Possible duplicate of ALERT! /dev/disk/by-uuid/xxxxxxxxx does not exist. Dropping to a shell – Yaron Jan 30 '18 at 13:05
  • Sorry, forget to add that I did try that solution. It's added to the question now. – Stephan Vierkant Jan 30 '18 at 13:27
  • 1
    Problem found: I had to switch to legacy boot to get access to both the pendrive and hard disk, but had to switch back to UEFI to get the hard disk bootable as it was. – Stephan Vierkant Jan 30 '18 at 14:10
  • You might want to use the info in your comment (detailed version) as an answer to your question – Yaron Jan 31 '18 at 9:05
  • If you solved your problem yourself, please answer your own question and accept your answer. Don’t put the answer in your question or the comments! Send me a message in the comments if you want my up-vote. :-) – David Foerster Jan 31 '18 at 14:20
4
+25

The answer is contained within your fstab file itself:

# / was on /dev/nvme0n1p3 during installation
UUID=dd84f4b3-d5bf-42e4-9b5e-ec685a461fad /               ext4    errors=remount-ro 0       1

# /boot/efi was on /dev/nvme0n1p1 during installation
UUID=B38D-559B  /boot/efi       vfat    umask=0077      0       1
# swap was on /dev/nvme0n1p4 during installation
UUID=f4134c38-10b9-478f-b550-54650a9f5140 none            swap    sw              0       0

so replace the UIDs with the oldfashioned names in your fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system>  <mount point>   <type>  <options>       <dump>  <pass>
/dev/nvme0n1p3   /               ext4    errors=remount-ro 0       1
/dev/nvme0n1p1   /boot/efi       vfat    umask=0077      0       1
/dev/nvme0n1p4   none            swap    sw              0       0

and reboot.

If that doesn't solve your problem 100%, the true error lies deeper and you will have to compare your UEFI settings between the old and new MoBo.

  • That doesn't make any difference :(. – Stephan Vierkant Jul 7 '18 at 11:07
  • Both UEFI and BIOS mode? (Sorry, if it doesn't help, I'll delete my answer). How did you get the BLKIDs? In another machine or by booting a USB/DVD ? /dev/sda is a 32GB USB stick? – Fabby Jul 7 '18 at 11:11
  • With UEFI it goes to Busybox, with BIOS 'no boot device', but with BIOS enabled and manually selecting UEFI it boots normally. Very strange. – Stephan Vierkant Jul 7 '18 at 11:21
  • OK, so it does work... Hmmmm, Can you drop by in chat and ping me there?? – Fabby Jul 7 '18 at 11:32
  • When I disable Legacy Boot/BIOS, my SSD doesn't show up when using a Ubuntu Live CD. Maybe that's relevant? – Stephan Vierkant Jul 7 '18 at 13:53
4

When I tried to use a pendrive Ubuntu to figure out this problem, I finally found out that the hard drive wasn't recognized when Legacy Boot was disabled. This explained why manually choosing UEFI did work.

The problem was that the new motherboard had the default settings, so RAID was enabled. Switching to AHCI solved my problem. This were the steps needed to change it: (borrowed from This answer)

  1. Boot into BIOS (F12 at startup)
  2. Select Bios Setup
  3. Move to System ConfigurationSATA Operation and select AHCI
  • An edit and an upvote. You should have your 50 rep nearly back by now... ;-) – Fabby Jul 8 '18 at 20:16
  • And you should probably award the bounty to @Fabby too :) – WinEunuuchs2Unix Jul 10 '18 at 0:00
  • @WinEunuuchs2Unix No! He should do nothing and not award anything, then the bountry will be automatically split. – Fabby Jul 10 '18 at 8:25
  • @Fabby The OP can't get half his own bounty right? So half will be lost and you will get the other half right? – WinEunuuchs2Unix Jul 10 '18 at 9:59
  • yup. @WinEunuuchs2Unix – Fabby Jul 10 '18 at 11:25
-1

I had this problem too where blkid confirmed the UUID in the alert was correct. Fixed it by changing my EFI partition to 500 MB and my root partition to 20 GB. Apparently some older BIOS don't like root volumes over 25gb

Edit: actually I was able to expand root to 100gb in GParted after successfully booting into the OS. Perhaps it was the 500 MB EFI partition that actually fixed it. Not sure.

  • My disk lay-out hasn't changed after the motherboard replacement, so that can't be the problem in my case. – Stephan Vierkant Jul 4 '18 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.