I have a dual boot system installed following blog - Ubuntu 16.04 with windows 10 along with an additional swap partition. It was working fine for several months and something like no boot device detected appeared after a shutdown (I'm not sure about the reason, but I had installed somethings Software Updater suggested). On the next restart, monitor went to power saving mode and I had to shutdown using the power button. It remained the same for two other attempts, then I reconnected everything from RAM, SATA cables, power cables etc and cleaned dust all over.

Now, system shows some message like:

watchdog=1 notification connection refused

And cursor blinks on a black screen. Some type of repeated messages are printed at almost same time intervals. Starting words are:

Modules linked in
Hardware name
---end trace ---

Along with some HEX codes and ? symbols.

If I tried to login with Ctrl + Alt + F*, it prints:

/dev/sda3: recovering journal
/dev/sda3: clean *** / *** files, *** / *** blocks

On the next keypress:

agetty[949]: segfault at *** ip *** sp *** error 14 in locale-archeive[***]

I have tried to see the contents from Grub menu. There is (hd0,msdos3)/ with /boot/grub and other system directories. (hd0,msdos2) and (hd0,msdos4) with /home contents and windows partitions. Remaining (hd0,msdos1) shows unknown filesystem.

How can I correct the errors? Or at least copy the contents and reinstall Ubuntu?


Booting from live USB shows:

32 bit relocation outside of kernel!
-- system halted!


On upstart:

/dev/sda3 contains a file system with errors, check forced.
Deleted inode 3670025 has zero dtime. FIXED.
/dev/sda3: 373516/9158656 files (0.2% non-contiguous), 2754152/36621093 blocks.
fsck exited with status code 1
[ 19.752709 ] upstart[1]: segfault at 5 ip ...
[ 19.768565 ] --- [end Kernel panic - not syncing: attempted to kill init! exitcode=0x00000000b
  • Van you boot an old kernel
    – Panther
    Jan 30, 2018 at 6:07
  • sounds like HDD failure. did you run a SMART test on the drive?
    – ravery
    Jan 30, 2018 at 6:15
  • @Panther it also fails, even a bootable USB get stucks! :(
    – Midhun KM
    Jan 30, 2018 at 6:23
  • @ravery SMART test , badblocks, fsck, everything tried
    – Midhun KM
    Jan 30, 2018 at 6:24
  • Does windows boot?
    – Panther
    Jan 30, 2018 at 6:32

1 Answer 1


I hope someone will land here frustrated the way I was, so save yourself before trying to recover a bad file system / boot device error.

I was having a bad RAM at one of the 4 slots. So, I would like to remind you to do a memtest from the grub menu before you proceed anything with Harddisk drive.

Also, you may be lucky enough to use the error-free part of RAM, read section :-

BADRAM setting in Grub2

If you proceed to do more tests with HDDs, you may end up with file system errors which are not easy to recover.

see the comment here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.