3

I want to install ns2.35 on Ubuntu 14.04. When I implement this command:

$ sudo apt-get install tcl8.5-dev tk8.5-dev
Reading package lists... Done
Building dependency tree  
Reading state information... Done
E: Unable to locate package tcl8.5-dev
E: Couldn't find any package by regex 'tcl8.5-dev'
E: Unable to locate package tk8.5-dev
E: Couldn't find any package by regex 'tk8.5-dev'

What should I do for resolving this problem?

  • Those packages exist; check your sources. – fkraiem Jan 30 '18 at 6:08
  • I have downloaded package tcl8.5-dev and package tk8.5-dev but I don't know how can I install them. I am a new user of Ubuntu. – lafille Jan 30 '18 at 6:49
  • @lafille you can install *.deb files by sudo dpkg -i file.deb or sudo dpkg -i /location/file.deb – Pavel Sayekat Jan 30 '18 at 7:26
  • @ChaiT.Rex: Tcl and Tk are in the main pocket in Trusty. – David Foerster Jan 30 '18 at 8:25
3

These packages exist and they are available in Ubuntu 14.04, here is the output of your command in my Ubuntu 14.04.4:

galoget@hackem:~$ sudo apt install tcl8.5-dev tk8.5-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libfontconfig1-dev libfreetype6 libfreetype6-dev libpng12-dev
  libpthread-stubs0-dev libtcl8.5 libtk8.5 libx11-dev libx11-doc libxau-dev
  libxcb1-dev libxdmcp-dev libxext-dev libxft-dev libxrender-dev libxss-dev
  tcl8.5 tk8.5 x11proto-core-dev x11proto-input-dev x11proto-kb-dev
  x11proto-render-dev x11proto-scrnsaver-dev x11proto-xext-dev
  xorg-sgml-doctools xtrans-dev
Suggested packages:
  libxcb-doc libxext-doc tcl-tclreadline tcl8.5-doc tk8.5-doc
The following NEW packages will be installed:
  libfontconfig1-dev libfreetype6-dev libpng12-dev libpthread-stubs0-dev
  libtcl8.5 libtk8.5 libx11-dev libx11-doc libxau-dev libxcb1-dev libxdmcp-dev
  libxext-dev libxft-dev libxrender-dev libxss-dev tcl8.5 tcl8.5-dev tk8.5
  tk8.5-dev x11proto-core-dev x11proto-input-dev x11proto-kb-dev
  x11proto-render-dev x11proto-scrnsaver-dev x11proto-xext-dev
  xorg-sgml-doctools xtrans-dev
The following packages will be upgraded:
  libfreetype6
1 upgraded, 27 newly installed, 0 to remove and 261 not upgraded.
Need to get 8.262 kB of archives.
After this operation, 37,2 MB of additional disk space will be used.
Do you want to continue? [Y/n] 

A tip, you can search for any package for any release version of Ubuntu in this website, and also you can download the files from that site, here are the two packages that you're trying to install:

Once downloaded the .DEB files, to install them, just follow these steps:

  • Assuming the .DEB files are for am64 and are located in ~/Downloads:

    cd ~/Downloads
    sudo dpkg -i tcl8.5-dev_8.5.15-2ubuntu1_amd64.deb
    sudo dpkg -i tk8.5-dev_8.5.15-2ubuntu3_amd64.deb
    

But I believe you're going to need some dependencies for those 2 packages to be installed correctly and work, you can check the output of my terminal at the beginning.

  • I tried to install tcl8.5 and tk8.5. After doing this I received these errors: – lafille Jan 30 '18 at 8:48
  • 1
    It is a good idea to publish your updates by editing your original post. – galoget Jan 30 '18 at 8:49
0

Try to add main repository with

sudo add-apt-repository main

And retry installation

sudo apt-get update
sudo apt-get install tcl8.5-dev tk8.5-dev

Not the answer you're looking for? Browse other questions tagged or ask your own question.