7

I have Blank screen disabled but my PC seems to be ignoring this. This issue also ignores the Caffeine extension. This is pretty recent behavior as it's been working for a long while now.

Power settings

Disabling idle-dim in dconf seems to have done it.

4
3

This is from another answer I posted recently. You may not need the Login screen section.

Terminal CLI method

To prevent screen from turning off you need two settings, one under battery power the other when plugged into wall outlet (A/C).

For battery timeout:

gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout <time_in_seconds>

For AC timeout:

gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout <time_in_seconds>

So for both Battery and A/C set the time to 0 (never).

For Login screen:

gsettings set org.gnome.desktop.screensaver idle-activation-enabled false

Disable dimming screen when idle:

In Unix & Linux someone complained when on battery screen dims every 20 seconds and wants to turn that feature off:

gsettings set org.gnome.settings-daemon.plugins.power idle-dim false
4
  • I'm on a desktop so I don't think those apply. They're both set to 'nothing' either way. The third suggestion was already disabled. There is an idle-dim option that's enabled though. I'll try disabling that. – Ubuntuthrow Jan 30 '18 at 19:24
  • Did the idle-dim work? I'm curious why you accepted my answer if it was incomplete? None-the-less I'm adding idle-dim to the answer. – WinEunuuchs2Unix Jan 31 '18 at 0:44
  • Sorry, I accepted it because it led me to that option. If that was wrong my bad. I left my screen on for 40 minutes while I did other stuff and it didn't turn off so yes I think that worked. – Ubuntuthrow Feb 1 '18 at 0:35
  • I'm not complaining that you accepted it... I added the idledim` option to the answer so it will help others. Just let me know if the answer is correct now is all I ask. Thanks. – WinEunuuchs2Unix Feb 1 '18 at 0:43
0

Nothing in the accepted answer has worked for me in 18.04. Instead I had to do the following:

gsettings set org.gnome.settings-daemon.plugins.power idle-brightness 100

Note that this doesn't set the idle to 100% of the max but 100% of the current setting (at least I think that's what it's doing). If you have your screen dimmed already it will stay dimmed.

0

I just want to add, that as a troubleshooting step w.r.t. my ...

Conspiratorially derived answer, that Ubuntu "Did Not Want" me logged into "Gnome on Xorg" ... as it sure seemed.

After a restart and the issue gone ... again, I specifically logged out of "Ubuntu" and logged back in via "Gnome on Xorg",

and No Problems! Issue APPEARS gone still?? (all other things being equal)

... So what has changed since this morning?

You tell me!

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.