2

I'm having serious problems with the wireless connection in my laptop. I have a Lenovo G400, originally with Windows 8.1. I was using Ubuntu 16.04 LTS since a year ago. Suddenly, one morning, I turn on my laptop and the wireless connection didn't work. In the top right corner, where my name is, the option Enable Wi-Fi dissapeared. That day, curiously, in Network options, I could connect to Wi-Fi. The next day I just couldn't do it, and since that, I've tried a lot of things to solve my problem. (Wired Connection works perfectly).

I tried a lot of things based on this thread (an amazing thread). After the failure I decided delete my disk and reinstall Ubuntu.

I reinstalled Ubuntu a couple of times, and the problem persists. Finally I reinstalled Ubuntu for the third time but in the Installation procces I uncheck the option "Download updates while installing Ubuntu" as can viewed on this image. And magically the WiFi options appeared!

As I reinstalled everything I started to installing the apps I had before but when I go to ´Software Updater´ and update everything the problem appeared again.

I reboot the laptop and it shows A system error ocurred. In details the error ocurred with bcmwl-kernel-source but I lost the exact information of the error. Then, based on the aforementioned thread I tried to install the driver in offline mode (downloading the packages and running in the folder sudo dpkg -i *.deb. The following info appeared:

dpkg: warning: downgrading bcmwl-kernel-source from 6.30.223.271+bdcom-0ubuntu1~1.1 to 6.30.223.248+bdcom-0ubuntu8
(Reading database ... 223629 files and directories currently installed.)
Preparing to unpack bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu8_amd64.deb ...
Removing all DKMS Modules
Done.
Unpacking bcmwl-kernel-source (6.30.223.248+bdcom-0ubuntu8) over (6.30.223.271+bdcom-0ubuntu1~1.1) ...
dpkg: warning: downgrading dkms from 2.2.0.3-2ubuntu11.5 to 2.2.0.3-2ubuntu11
Preparing to unpack dkms_2.2.0.3-2ubuntu11_all.deb ...
Unpacking dkms (2.2.0.3-2ubuntu11) over (2.2.0.3-2ubuntu11.5) ...
Preparing to unpack libc6-dev_2.23-0ubuntu10_amd64.deb ...
Unpacking libc6-dev:amd64 (2.23-0ubuntu10) over (2.23-0ubuntu10) ...
Preparing to unpack linux-libc-dev_4.4.0-112.135_amd64.deb ...
Unpacking linux-libc-dev:amd64 (4.4.0-112.135) over (4.4.0-112.135) ...
Setting up dkms (2.2.0.3-2ubuntu11) ...
Installing new version of config file /etc/kernel/prerm.d/dkms ...
Setting up linux-libc-dev:amd64 (4.4.0-112.135) ...
Setting up libc6-dev:amd64 (2.23-0ubuntu10) ...
Setting up bcmwl-kernel-source (6.30.223.248+bdcom-0ubuntu8) ...
Loading new bcmwl-6.30.223.248+bdcom DKMS files...
Building only for 4.13.0-32-generic
Building for architecture x86_64
Building initial module for 4.13.0-32-generic
ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/bcmwl-kernel-source.0.crash'
Error! Bad return status for module build on kernel: 4.13.0-32-generic (x86_64)
Consult /var/lib/dkms/bcmwl/6.30.223.248+bdcom/build/make.log for more information.
modprobe: FATAL: Module wl not found in directory /lib/modules/4.13.0-32-generic
update-initramfs: deferring update (trigger activated)
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for initramfs-tools (0.122ubuntu8.9) ...
update-initramfs: Generating /boot/initrd.img-4.13.0-32-generic

This is all the information I can give, I apologize if it is too long but I think it can help. Thanks in advance for any help. IMHO (I'm some newby in Ubuntu), I think the problem is with the new version of the driver. If it is, how can I avoid the upgrade of the driver? (I don't put another thread for this because I'm unsure that's the problem).


Update

Ok. I've made a fresh install again. When I run apt list --installed | grep 4.10.0-28-generic, it shows,

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

linux-headers-4.10.0-28-generic/xenial-security,now 4.10.0-28.32~16.04.2 amd64 [installed,automatic]
linux-image-4.10.0-28-generic/xenial-security,now 4.10.0-28.32~16.04.2 amd64 [installed,automatic]
linux-image-extra-4.10.0-28-generic/xenial-security,now 4.10.0-28.32~16.04.2 amd64 [installed,automatic]
linux-signed-image-4.10.0-28-generic/xenial-security,now 4.10.0-28.32~16.04.2 amd64 [installed,automatic]
3
  • You should consider doing a fresh install again and then pin the kernel at that version which works. Automatically upgrading the kernel to version 4.13.0-32 appears to make it incompatible with your broadcom driver. Alternatively find a new broadcom driver. Jan 30, 2018 at 12:13
  • @WinEunuuchs2Unix Could you tell me how to do it? How to pin the kernel version.
    – Byag
    Jan 30, 2018 at 16:41
  • I posted an answer to pin the kernel after installation and before update. Jan 31, 2018 at 1:06

1 Answer 1

1

Update is breaking your system

After installing DO NOT update your software.

Find out your kernel version with uname -r:

$ uname -r
4.14.15-041415-generic

Find out the specific package names

Replace 4.14.15-041415-generic below with what your uname -r returned above:

$ apt list --installed | grep 4.14.15-041415-generic

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

linux-headers-4.14.15-041415-generic/now 4.14.15-041415.201801231530 amd64 [installed,local]
linux-image-4.14.15-041415-generic/now 4.14.15-041415.201801231530 amd64 [installed,local]

Pin the packages so they don't get updated

Replace 4.14.15-041415-generic below with what your uname -r returned above:

$ sudo apt-mark hold linux-headers-4.14.15-041415-generic
linux-headers-4.14.15-041415-generic set on hold.
$ sudo apt-mark hold linux-image-4.14.15-041415-generic
linux-image-4.14.15-041415-generic set on hold.

Note: Rather than retyping, copy and pasting portions from above section will save time and reduce errors

Now it's safe to update your software

You can update your software through the software centre or using:

sudo apt update
sudo apt upgrade
9
  • First at all, thanks a lot, this is important to me. I tried you told me but when I run sudo apt upgrade the packages that I hold are still updating (and the problem appears again). It shows something like System Problem and when I see the details is with bcmwl-kernel-source
    – Byag
    Feb 10, 2018 at 15:42
  • @Edonbrayn After you upgrade what does uname -r reveal is the booted kernel? Also when you rebooted did you go into Advanced Options in grub menu and select kernel version 4.4.0-112? Feb 10, 2018 at 15:46
  • @Edonbrayn OK so it is kernel version 4.10.0-28.32 that works for you and that is the version you want to pin correct? If so follow the instructions above but replace 4.14.15... with 4.10.0-28.... Feb 10, 2018 at 16:06
  • Sorry. The caracters for comments were too short for the entire info. I've just updated the post with the info I tried to told you before. I'm going to pin the packages
    – Byag
    Feb 10, 2018 at 16:08
  • I've just run sudo apt-mark hold... with all the packages that show me the command apt list --installed | grep 4.10.0-28-generic. But when I run sudo apt-cache policy the packages don't appear in the Pinned Packages list (nothings appears there). I'm telling you this because as I told you before the last time I tried this when the system was upgrading I see that also upgrade the packages that I pinned
    – Byag
    Feb 10, 2018 at 16:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.