I'm trying to make the Hardware Video Decode works on an Intel NUC7i3 (with Intel HD Graphics 620). My goal is being able to play smoothly 4K H.264 videos in the browser.

Here is a summary of my situation:

  • I've installed Xubuntu 17.10 (secure boot is disabled), third party drivers/codecs has been enabled during the installation.
  • I've installed Chromium version 64 from saiarcot895 PPA that has an hard-coded enabled hardware acceleration.
  • I've switch to "Enable" the Chromium Flags "Accelerated Video Decode" and "Override Software Rendering List".
  • chrome://gpu gives me "Video Decode: Hardware accelerated"
  • I play a 4K H.264 video in a tab
  • In another tab I user chrome://media-internals and I can read that FFMpegVideoDecode is use to play the video (software decoding).

I'm looking to obtain "GPUVideoDecode" instead of "FFMpeg..." which is the only reliable indicator that the hardware video decode is used.

How can I do the enable the hardware acceleration ?

  • Do you have intel-microcode installed? – dobey Jan 29 '18 at 15:21
  • I've just installed it. Nothing better... any other advice? – Poltergeist Jan 29 '18 at 22:38
  • Can you play the same video with mpv --hwdec=vaapi? Just to check your intel driver is working. – Sebastian Stark Mar 27 '18 at 0:19
  • yes mpv with vaapi worked. problem was about the version 64. thanks for your help. – Poltergeist Mar 30 '18 at 12:55

I was able to solve the problem by upgrading to version 65 or 66. According to the maintainer for this PPA, this problem is related to something which is probably missing in the 64 version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.