1

I have a synology NAS. On the client I create the directory :

mkdir /media/feydreva/download
chown -R feydreva /media/feydreva
chmod 777 /media/feydreva/download

I can mount my NFS without any issue :

sudo mount -t nfs 10.2.1.3:/volume1/download /media/feydreva/download

I can create file and directories into it

mkdir /media/feydreva/download/AAA 
touch /media/feydreva/download/aaaa.test

But, when I use ubuntu explorer (nautilus), annd I go to that directory, I cannot create new folder. I cannot save file into it. I can go into the AAA directory, and here I can create folder and save file.

Interresting thing is that with Libreoffice, I can create a directory and save a file into /media/feydreva/download/ ,only nautilus cannot.

id : uid=1026(feydreva) gid=1000(feydreva) groupes=1000(feydreva),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),118(lpadmin),128(sambashare)

 getfacl : suppression du premier « / » des noms de chemins absolus
# file: media/feydreva/download
# owner: feydreva
# group: feydreva
user::rwx
group::r-x
other::r-x

so today (02022018) : I tried changing the uid of "feydreva" my PC, to match the one of "feydreva" on the NAS. So i changee the uid to 1026. I did a sudo chown -R feydreva:feydreva /media/feydreva/download I still have the same exact issue: cannot write on /media/feydreva/download, but can in /media/feydreva/download/AAAA using nautilus, works fine in console/bsh or libreoffice..

Any idea or suggestions ?

  • /media/feydreva/ is further up the tree than your mount point at /media/feydreva/download so if your testing your ability to read and write to NFS your using the wrong directory and as such your question is unclear. – Elder Geek Jan 29 '18 at 15:22
  • Possible duplicate of askubuntu.com/questions/143905/… – Elder Geek Jan 29 '18 at 15:24
  • Could you please try to change the access permissions after you mount the (remote) file system? When a directory is used as a mount point its properties, including access permissions, are overridden by those of the root directory of the mounted tree. – David Foerster Jan 29 '18 at 17:47
  • OK, sorry for the confusion, I can create file and directories into it using a console /shell >mkdir /media/feydreva/downnload/AAA >touch /media/feydreva/download/aaaa.test but I cannnot savee file, nor create directories using the file explorer Nautilus. – Feydreva Jan 30 '18 at 16:36
  • @DavidFoerster : I did change the permission of the directory of the mount point after the mount is done, and I have same results. the funnny thing is that it is just with Nautilus I just tried creating a document with Libreoffice and save it, I can save it in the directory. I also tried to create a direcotry into the mount with libreoffice and it works. – Feydreva Jan 30 '18 at 16:40
1

It is not merely a bug in Nautilus. I use nemo as my regular file manager and it exhibit the same behavior.

When I use PCManFM, it works.

PCManFM uses a different type of graphic library. I suspect the problem is more on the gnome side.

| improve this answer | |
0

I have the same problem with my NAS synology, and an NFS mount. The mount point is root:root, and is not to be writen by users. It's necessary to create other folders under this point, using sudo. Then, it's possible for users to read and write in these subfolders. But not with NAUTILUS ! So, I installed an other file manager (PCManFM), and with PCManFM, it's possible to write in these subfolders.

Conclusion : this is a bug of NAUTILUS !!!

| improve this answer | |
  • how to you report a bug for nautilus ? – Feydreva Mar 27 '18 at 14:54
0

1.5 year later, Nautilus 3.32.1, still has the same issue. I used thunar for daily stuff, but some programme uses Nautilus by default sometimes..

| improve this answer | |
0

I had the same issue with Caja (MATE) and an NFSv4 server exporting:

/export (ro,insecure,no_subtree_check,anonuid=1000,anongid=1000,crossmnt,fsid=0)
/export/data (rw,insecure,no_subtree_check,anonuid=1000,anongid=1000)
/export/downloads (rw,insecure,no_subtree_check,anonuid=1000,anongid=1000)
/export/home (rw,insecure,no_subtree_check,anonuid=1000,anongid=1000)

Where data, downloads, home are bind mounts to directories on a single filesystem.

Adding a unique fsid to each entry solves it for me.

/export (ro,insecure,no_subtree_check,anonuid=1000,anongid=1000,crossmnt,fsid=0)
/export/data (rw,insecure,no_subtree_check,anonuid=1000,anongid=1000, fsid=1)
/export/downloads (rw,insecure,no_subtree_check,anonuid=1000,anongid=1000, fsid=2)
/export/home (rw,insecure,no_subtree_check,anonuid=1000,anongid=1000, fsid=3)
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.