1

When compilation gulp I get the following error:

LoadError on line ["55"] of /usr/lib/ruby/2.3.0/rubygems/core_ext/kernel_require.rb: cannot load such file -- compass-normalize Run with --trace to see the full backtrace

I'm using the below version of ruby and compass:

$ ruby -v
ruby 2.3.3p222 (2016-11-21) [x86_64-linux-gnu]

$ compass -v
Compass 1.0.3 (Polaris)
Copyright (c) 2008-2018 Chris Eppstein
Released under the MIT License.

How to install compass-normalize in ubuntu?

3
1

According to compass-normalize git hub

Installation

It is highly encouraged to install from the RubyGems build which can be found here.

From the command line:

$ gem install compass-normalize

You can also install the gem from your local clone:

$ git clone git://github.com/ksmandersen/compass-normalize.git
$ rake build
$ rake install

Usage

When creating a new project with compass:

$ compass create <my_project> -r compass-normalize --using compass-normalize

If using an existing project, edit your config.rb and add this line:

require 'compass-normalize'

To use the normalize plugin, just import and include normalize:

@import "normalize";

Note: SO Q&A discussion sudo-gem-install-or-gem-install-and-gem-locations

  1. You can also install gems in your local environment (without sudo) with

    gem install --user-install

  2. I recommend you install RVM and start a happy life with portable gem homes and different version of Ruby all living under one roof.


Regarding the second question mentioned in the comments below regarding DEPRECATION WARNING:

There is a known issue in compass which was mentioned here

A branch with fix was published here, updating compass with the fix can be done using:

git 'https://github.com/ably-forks/compass', branch: 'sass-deprecation-warning-fix' do
  gem 'compass-core'
end

Similar issue was mentioned here

8
  • gem install compass-normalize ERROR: While executing gem ... (Gem::FilePermissionError) You don't have write permissions for the /var/lib/gems/2.3.0 directory. – Владимир Владимирович Jan 29 '18 at 10:13
  • Your gem command tries to install it as root you can execute the gem command as root using sudo however other methods are recommended - Please review this SO-Q&A how to install gem without using sudo – Yaron Jan 29 '18 at 10:25
  • i write sudo gem install compass-normalize. Gulp working but, i have new problem after command gulp. – Владимир Владимирович Jan 29 '18 at 10:53
  • DEPRECATION WARNING on line 87 of /usr/share/compass/frameworks/compass/stylesheets/compass/css3/_deprecated-support.scss: #{} interpolation near operators will be simplified in a future version of Sass. To preserve the current behavior, use quotes: unquote('"$moz-"#{$experimental-support-for-mozilla} "$webkit-"#{$experimental-support-for-webkit} "$opera-"#{$experimental-support-for-opera} "$microsoft-"#{$experimental-support-for-microsoft} "$khtml-"#{$experimental-support-for-khtml}') You can use the sass-convert command to automatically fix most cases. – Владимир Владимирович Jan 29 '18 at 10:54
  • 1
    Good luck!Im glad to see you – Владимир Владимирович Jan 29 '18 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.