I have seen a lot of questions related to Bridge and network manager. however none of them seem to apply to what i seen AND want.

I setup my bridge in /etc/network/interfaces. This works perfectly; it uses a nice static ip etc.

However once I rebooted, the network manager says it is unmanaged (as in it can't manage the bridge/connections).

Now this would normally be fine, but I kind of need/want something else on this computer as well.

The first question is: Is it possible using openVPN (or any other vpn) connection on a bridged interface?

If so, how do I get Network Manager to manage the bridged interface? (as at this point VPN is set up there, but doesn't work/connect because it's unmanaged.)

  • ifconfig & cat /etc/network/interfaces < update
    – One Zero
    Jan 31, 2012 at 4:48

3 Answers 3


Unfortunately, I keep answering my own questions aparently. But just to share with others..

Bridge + openvpn works BUT internal network only. AND has an odd bug that openvpn re-connects it self making multiple TAP devices (I use tap method).

In the end i solved my problem this way:

  1. go back to the normal Network management - default system stuff.
  2. Add an additional ip (leave gateway blank)
  3. Add ipv4 forward enabled
  4. Add iptables DMZ rules (forwarding your additional ip on eth0 to the vm - and vice versa).

The weirdest problem about ubuntu is it seems to forget all iptables and ipv4 forward enbaled (sysctl) settings on a reboot.

so, just add it to rc.local and it will work fine on every boot/reboot :)

If you need exact details for the setup, just give me a ring. ;)

  • 1
    Unfortunately you DIDN't answer your own question, your question was how to bridge without destroying network-manager, your answer essentially is to not use network-manager. The "destroyed" status of network-manager becomes irrelevant, as does this answer. Oct 25, 2012 at 22:45

In Ubuntu 12.10 it is not possible to use bridged networking with the network manager on the same network interface. The device used for bridging must be set to manual in /etc/network/interfaces which excludes it from network manager. For setting up a bridge, follow the instructions of the Ubuntu community help. What works is to have eth0 bridget and e.g. wlan0 managed by network manager. So it is possible to connect to wifi networks conveniently. Unfortunately this does not work for OpenVPN connections. Hence one will have to start them manually with sudo openvpn /etc/openvpn/client.confm given that the client configuration file is created. But there is seems to be help, people from the Fedora project are working to implement bridged networking into the Network manager. It is expected to Fedora 20.

  • 1
    Network-manager 0.9.8 has been just released and has the above described functionality. It will be available in Ubuntu 13.04.
    – user54914
    Mar 28, 2013 at 9:03

Bridging with NetworkManager finally works for me in 15.04 beta (with VPN). In 14.04 it didn't, not sure about 14.10.

  1. Delete Wired Connections for interfaces you want to bridge (eth0, eth1, ...)
  2. Add -> Virtual -> Bridge
  3. Bridged Connections -> Add -> Ethernet
  4. Choose MAC of port you want to bridge, Save
  5. General -> Automatically Connect
  6. Save the bridge

You may have to disconnect/connect, but for me it came up with no problem. This page was helpful:


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.